How to turn Autoplay off in Microsoftt Edge?

It’s really annoying when I open an article on CNN (or another website) and a video starts playing. I found these instructions to turn Autoplay off:

Disable media autoplay in Microsoft Edge

  1. Open the Microsoft Edge web browser.
  2. Click on the menu icon (the three dots) and select Settings.
  3. Switch to the Advanced category in Settings.
  4. Locate Media Autoplay in the menu that opens.
  5. Set the autoplay functionality to allow, limit or block .

OK, so I click the ellipsis, I click on Settings, and… There’s no Advanced category.

So how do I turn off Autoplay in MS Edge?

Type autoplay in the search box.

I tried that, but didn’t see it. I assumed that only the results of the search would be shown. I had to scroll down, and then I saw the one result in ‘Media Autoplay’.

My options were ‘allow’ and ‘limit’. I went back to the CNN page after choosing ‘limit’, and the video still played because it played before. There was no ‘block’ option.

I think that the problem is that the modern web can “automatically” play content in a number of ways, and it is not possible for a browser to detect which are ‘automatic’ and which are you making a deliberate choice. So Edge can only claim to ‘limit’ it.

An option would be to turn off video entirely, so that it can’t play at all (like Edge does for Flash). I don’t think Edge offers that option.

Browsers (not just Edge) have moved away from allowing you to turn off JavaScript and downloads, claiming (correctly), that modern websites ‘need’ JavaScript and media downloads, and suggesting that allowing users to turn stuff off ‘breaks’ the web, and facilities to allow that should not be exposed in the normal user interface. I don’t defend this practice, merely note it.

(I’m using Edge. In Cafe Society, threads with linked video periodically burst into life, with all the video that I’ve viewed starting up again. Perhaps people over there are more likely to know something helpful.)

Was that old Edge or new Chromium based Edge? Check the date on the article.

It’s under “Cookies and site permissions” / Media Autoplay

If this browser is on a computer controlled by your employer, they may well have eliminated your ability to get to those settings. One of the features of most MSFT end user software (not just Windows itself) is that it can be heavily controlled by the administrators of your workplace.

… one of the features of Edge (and Firefox), is that a lot of stuff has moved or just disappeared. Unfortunately, a lot of the information available on the web is (now), just wrong, as in this instance.

One can disable javascript globally in Chrome, and manually construct black- and white-lists, using this control page: chrome://settings/content/javascript

There are similar options in Firefox (with extensions that simplify the experience).

I don’t and won’t use Edge, so I can’t speak to the options there.

This is one of the way I manage intrusive websites: turn off javascript, and then re-activate component calls one by one until the webpage is minimally functional.

Warning, this method is a lot of time and effort. When you first turn off javascript, nothing will work correctly, and every page and site will be completely broken. It’s actually pretty illuminating, seeing firsthand just how much scripting goes into the modern Web. So, at the beginning, you’ll spend many minutes hunting for the functions that restore your commonly-used pages. However, this decreases over time, as you white-list the master components that get used across many sites, and eventually you get back to a relatively smooth experience where the stuff you want to see is working and the stuff you don’t want is removed.