HTML Question ?

I am using dreamweaver 3.0 and for some reason it puts huge spaces between the lines of html code. does anyone know how to stop this and also how to get rid of the spaces that are already there?

I wouldn’t worry too much about it… spaces between lines of code are irrelevant.

Dreamweaver, AFAIK, has always put in those spaces so that the user could read the HTML code easier. But since the spaces don’t add any file size, and browsers ignore them, it’s really not a big deal.

If you really do want to get rid of them, you’ll have to open the file in Notepad (I’m assuming you use Windoze here, perhaps some of our Mac-using fellow Dopers could explain this otherwise), and edit there. Dreamweaver will keep dropping them in, no matter what.

You can pick a separate external editor by clicking on the “External Editor” button on the HTML Source window. This might help you a bit.

Of coures, until I see an example of the offending code, I really am just talking out of my @$$ on this. The code for the site in your sig file looks fine, except you’ve got a bad META tag on the frames page. You’ve got a list of keywords, but you’ve got it designated as a description. Just change <META NAME=“description” (deletia)> to <META NAME=“Keywords” (deletia)> and you’ll be fine.

Let me know if this has been any help at all…

well it does add to the file size,
i manually removed it from one file to compare and it is true.

you can look at this page to see what i’m talking about:

this file eventually became over 500 kb!!

That HTML is really screwed up. I’ve used Dreamweaver for years and I’ve never seen it do that. If you’re using Dreamweaver to edit the file directly from the server, make sure the line breaks are set to the type of server you’re using. If you’re using a Unix server and the line breaks are set to Windows format (CR + LF), it’s possible it will add a blank line every time you upload. It’s just a guess.

There are various text utilities that will fix the text that’s already messed up. I know it’s possible to create an UltraEdit script that will fix it.

You might like to know that your huge file causes the Solaris version of Netscape 4.7 to exit. No core dump - it just exits. I downloaded the file, and stripped off the empty lines, then it displayed.

The file was large enough that a global command in vi would have taken forever, so I ran it through sed:

sed -n -e “/^./p” crowenews.html >c2.html

(print only lines with a character on them. If you’re working on Windows, I strongly suggest getting some “UNIX for the PC” utilities for stuff like this. I like MKS - cygnus is inferior, but it’s free)

This is what I’m about to suggest. You set it in the Preferences panel (Edit/Preferences). Click on the HTML Format category.

Now I haven’t been able to duplicate your problem on my machine, but this is probably the solution. Closest thing to what’s happening with your files is the weird “breaks” I get using Macintosh line breaks. Without knowing what system you’re running, I can’t tell you which option you should be set up for.

As for your existing file, edit it manually using a bare-bones editor (I suggest WordPad, because this file is too big to use anything else to open it with) and (hours later :slight_smile: ) publish it using good ol’ FTP. For future edits, you can set Dreamweaver so it won’t frick around with your code by setting the HTML rewrite options, just to be on the safe side. Once again, you do that from Preferences.

BTW, when you said “extra spaces” I thought you had a few extraneous lines here and there, NOT the acres of white space between lines you have going on. Yes, that many spaces WILL tack on quite a bit to a file size. Guess that’ll teach me to spout “wisdom” before I have all the facts, huh? :smiley:

Hope this helps. Good luck!