I never thought I'd post a computer question...


I installed a new CD-R/RW. It worked fine for a day. Right around the time I downloaded shareware to copy ccd and img files and rebooted, neither cd drive was available to Windows. I checked the device manager, and I’m getting:
Your registry might be corrupted. (Code 19)

Any Suggestion on how I can get my cd[s] back?

I also posted in alt.os.windows2000, but but I’ve been a doper for so long, I had to share with all my buds.


Did you get all the latest updates for the copy utility? I had problems with my CD burner when I installed a sound card and it was just a conflict with Win2k and some ASAPI (?) drivers, but it had to do with the copy software i was using, not the sound card. I just got the tiny update from the software co. and all was well.

Sometimes when you get shareware from a place like download.com you should check out the product’s homepage for updates, in case they didn’t make it to download.com yet.

Thanks for the reply, ZipperJJ.
I got the copy utility from their own website, so it was the latest and greatest. Since then I’ve deleted that software. At this point I’ll be happy just to get my CD-ROM working again. I can’t get past the registry error I’m getting.


Does Windows 2000 have a system restore options? Check Start, Programs, Sccessories, System tools. Should be around there. If you have it let me know.

Are you getting the registry errors for both a previously installed CD drive and the new one?

A quick fix that sometimes works in cases like this is to right click on the devices in the Device Manager and have it remove the offending device(s). Then do the Add New Hardware from the control panel and let it redetect the devices. If the registry problem is in the section devoted to the device, that should correct the problem. But this sounds as if it may be deeper.

Nope. There that’s not there.

Yes, I’m getting the same corrupted registry error with with both CD devices. I’ve tried removing the offending device several times (Like it would miracleously work the 10th time I tried it) and it didn’t work. I even changed my bios to boot from CD and tried to boot off of my Win2K CD as that happens before Windows registry is even considered. I take a failure. Although when it’s in its bootup sequence it recognizes the device.


The following article from Microsoft doesn’t pertain exactly to the problem you are having, but I suspect the root cause is the same. At least it gives the registry entries that are pertinent to this situation as well as some potential fixes:

Code 31 Messages Occur After Removing Adaptec Easy CD Creator4.02c

Im not familiar with that OS but most microsfot OS’s let you boot to a disk then I would run scanreg /restore & restore a previous registry. also in the hardware profile you can delete the cd drives & restart the computer & it shold see them again.

Considering that the op posted that Win2000 does not have a registry restore and that he already tried to delete the drives from the profile, not very helpful. When my system decided to not see MY cd rom and cd rw, I ended up physically removing them from the system, booting, running Norton WinDoctor, shutting down, reinstalling and then rebooting. My system then saw the drives. If you DO have a program like Norton Utilities, run the registry checker through it and see what you get.

Hope you get things fixed :slight_smile:

I like Xploder’s suggestion of running the Norton registry scan.

W2k lets you swap the registry hives as a system restore. If the registry scan doesn’t work, you might want to try swapping the system hive. I worked win2k setup support for a while and I found the notes I took on how to do it. Here’s how:

  1. Boot from the windows 2000 CD. At the “welcome to setup” screen, press f10 to go to the recovery console.
  2. Select which installation of w2k you want to go into (probably only 1 to choose from).
  3. enter the Administrator account’s password.
  4. go to this directory: C:\winnt\system32\config
    At this directory, type: ren system system.old
    from the same directory, type: copy C:\winnt\repair\system
    Then type exit.

If this doesn’t work you could try the software hive, but you will likely have to re-install all your applications after.