Is my soundcard dead?

No sound coming out. I have done the following troubleshooting steps - am I missing anything easy/obvious before I buy a new soundcard?

Environment: HP Pavilion, Windows ME (please don’t poke fun)

– Not on mute
– Rebooted
– I have unplugged and replugged the speakers
– Tried a second set of speakers
– Went to Control Panel - no conflicts or problems with any devices - the Sound Control player has no errors
– Nothing has changed from my perspective, could spyware or a bad .MPG have done this?

I think the soundcard is built in (not in a PCI slot) - so what are my options for opening up the back and poking around?


It’s probably a driver issue. Go to the manufacturer’s website and download the latest drivers. You can also try uninstalling the soundcard in device manager and rebooting to see if that fixes it.

Did the sound stop working all of a sudden, or has it never worked? New drivers probably won’t help if your sound has worked in the past.

What sounds have you tried listening to? Games, CD, mp3s? What applications have you used?

Have you tested for ad/spyware and run a virus scan?

If you have on-motherboard sound, I imagine there’s not a whole lot you can do if it’s busted, save for buying a sound card.

Have the CMOS (or “BIOS”) settings been changed lately? If you have onboard sound then there will be some CMOS settings for that.

The CMOS settings can be reset for several reasons such as flashing a new BIOS, replacing the battery, or random acts of hardware.

The integrated sound/modem chipset on some of the Pavilions will occasionally lock up. To fix it

2: Make sure you have the specific sound card chipset drivers for Win ME on hand in a directory or on a CD.

3: Go into the hardware listing under the control panel folder and delete all the audio chipset drivers

4: Reboot the system. The sound hardware should be recognized and it will ask for the drivers.

5: After re-installing the drivers the sound card will reactivate.

If this fails it could be dead . But I have seen this locked out behavior several times on Pavilions and it’s usually an IRQ address confusion issue or something similar.

THANKS Alereon and astro!

Removing the drivers and re-installing did the trick (actually it worked under PnP; didn’t need to point to different drivers)

First time I have been happy with ME…

thanks guys!