It's impossible to watch !!!!

I was surfing the web when I come across this website containing homebrew, anti-Bush, political ads at Ok, so I click on the said movies to try to check out what it’s all about. The link takes me to a second page, with a big black void in the middle. I wait, and no movie. Since I was using Mozilla, I figure I don’t have quicktime and so go download it and install it. Try again, no luck. Ok, so I fire up IE 6. Same thing. I’m puzzled, since it’s a DSL connection. I give up for the day.

The next day I go to school, and they have awesome high-speed networks in the library. I hop on their new dual-head Apple machines, running OS X, and fire up IE. Still no movie, just a big black spot. I fire up Netscape. Same thing. I try Safari. Nope. I switch computers, and I get on a dual-head Dell machines, running XP. No movie shows up on IE. I try Thunderbird. Nope, sorry. I give up for the day.

After work today, I go to a different computer cluster. No bandwidth problems here. Windows 2000 computers, with IE 6 and Thunderbird. Nothing but black space where the movie is supposed to be.

I haven’t tried Linux yet. Should I?

There’s apparently some problem with their website - I’m getting the same non-results you are. And it’s not just a question of waiting for the download, or of having the right software to play the videos - my little activity indicator is showing me that there just aren’t any bits coming down the pipeline.

By golly, ten minutes after I post my little rant, the damn website starts working!! I’ve been trying to watch the movies for the past three days with no luck! :smack:

The HiRes/LoRes links that are on the front page point to pages that don’t work. (The media files aren’t where you would expect them to be upon scrutinizing the source.)

They are probably reorganizing the page and haven’t updated those pages yet.

In the meantime, the TOP 150 page that they’ve recently added links to pages that should work.

Personally, I hate imbedded video – especially since the media files themselves are .mpgs which don’t require Quicktime to view. (This is my way of saying that I haven’t actually seen the video playing in a plug-in, so I don’t know if that aspect of the page works, but it appears to be written in a way that it should work, if you follow me.)

Never mind. :smiley: