iTunes is truncating my music!

Well, not all of it. But I’ve noticed that when I load CDs on to iTunes, some of the tracks have their lengths shortened, down to between thirty seconds and a couple of minutes. This has only happened to a few CDs, but it’s frustrating. Reloading the CD makes no difference. I though it was annoying copy protection, given as I only noticed it on new release CDs, but tonight I found that my Dad’s Ella Fitzgerald CD, that’s easily ten years old, was doing the same thing. What gives iTunes?

Has anyone else had this problem, or know how I might get around it?

Is it actually cutting the track off? I know that you can manually set the length of the track to play, which can be handy when you are making a mix CD or something. But this shouldn’t happen by default when you’re importing a new CD.

It cuts the track off. I’ll see if manually setting it for the correct length makes a difference.

Nope. You can’t make the tracks longer than iTunes says they are

I’ve noticed iTunes has a setting for the tracks to fade out instead of playing completely. Seems to be the default, because I had to find it and turn it off. Probably doesn’t help in your case.

I’ve had my iPod cut off songs that were ripped with variable bit rate. Do the songs that are getting cut off have variable bit rates?

Not that I can see - the Ella Fitzgerald songs tracks are listed as having at bit rates of 160kbps, and half are full length and the rest are about 30 seconds each.

I’ve noticed a similar or same problem with certain MP3s that work fine in iTunes cutting short in the iPod. Like a 5 minute song would just stop 3 minutes in and then go to the next song.

Not sure what causes it, but I found that the following works:

Delete the song from iTunes (but not from your hard drive).
Synch up your iPod to remove the song.
Reload the song in iTunes
Synch you iPod again.

Usually that resolves the issue for me.

It may still be a vbr problem… you may want to check this out.

Oh yeah-- have you tried using another app to rip the CD’s? It may be a last resort idea, but it should work.

And after checking out the Apple support forums, it does look like there’s a bug in the software. Other people (though not a lot) are having the problem, with no real solutions being offered up. Someone suggested making sure your songs are or converting them to AAC format, but someone else said he was having the problem and all his songs were AAC.