Kindle help needed!

Just purchased the latest Kindle (wifi+3G). The first book I searched for on the storefront returned tons of results. Any subsequent searches I’m making, however, return zero results. Doesn’t matter what author or title I search for, I get zero results.

What am I doing wrong? Help! :confused:

maybe searching in the wrong bar?

Do you have wi-fi or 3G turned on? Make sure it’s on by checking menu in the home page.

You could also be searching in the “Kindle store” as opposed to the Amazon main store.

Can I jump in here with a add-on question? Isn’t it true that you can also use your Kindle to check out books from some libraries? Can someone give me some details about that? Maybe a few links or two that you think are reputable?

I’m not sure what you’re doing. I just now tried doing two searches in a row, and I didn’t have any problem.

Do you know that you can shop for books for your Kindle either via the Kindle itself, or by going to on a regular computer? I find the latter method easier and more convenient (at least when I’m at a computer, which I’m guessing you are to be posting here). Either way, any Kindle books you buy from Amazon will be wirelessly delivered to your Kindle.

Not yet, but it’s been announced that this will be available later this year.

Thank you all for replying. The problem is taken care of. In case anyone’s interested or faces a similar issue, here’s what happened.

My first search was before I registered my Kindle with Amazon; my second search was after. Apparently, the Kindle registered itself to the default Amazon (US) whereas I’m in the UK. I didn’t receive any prompts to switch registrations to Amazon UK either. So searches after registration returned zero results. After fiddling with settings and the Amazon website awhile, we discovered a Kindle administration page where we were prompted to switch countries. Viola! Searches okay now.

I’m not sure if the UI is intentionally crappy (unlikely, given the number of Kindle iterations) or it’s just another case of electronics disliking me on sight, but all problems solved.

Thank you all again!