linux dependencies

I must preface this by saying i am a linux n00b and don’t really like installing anything on linux because of the problems i always have.

When i run my rpm package i get these messages:

[root@server ibmtsm]# rpm -U gskcrypt64-
error: Failed dependencies: is needed by gskcrypt64-8.0-14.11.x86_64 is needed by gskcrypt64-8.0-14.11.x86_64 is needed by gskcrypt64-8.0-14.11.x86_64 is needed by gskcrypt64-8.0-14.11.x86_64 is needed by gskcrypt64-8.0-14.11.x86_64 is needed by gskcrypt64-8.0-14.11.x86_64 is needed by gskcrypt64-8.0-14.11.x86_64

A couple questions: which part of that diarrhea is the actual dependency? “” or “” or neither

I have tried half a dozen variations of the following to try and get the dependencies to install:

[root@cserver ~]# yum install libc*
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Excluding Packages from Amcom-RHEL4 - Updates
Parsing package install arguments
No Match for argument: libc*
Nothing to do

How else does one install the necessary dependencies onto this RedHat machine? I have also done yum whatprovides and i get a long obtuse list that doesn’t really help me much:

<snipped lots of diarrhea>

What needs to be done? It is soooo much easier to install this backup client on Window, by double clicking setup.exe and it just WORKS.

It looks like you’re trying to install a 64-bit package (hence the “x86_64” in the filename of the RPM) on a 32-bit operating system (which I gather from the “i686” directory output by yum whatprovides).

Look for a 32-bit package of gskcrypt64 (i.e., one with a filename like gskcrypt64- or such) and try installing it instead.

If you’re after ease of use, why are you trying to install this program from the command line? Why not just use your distribution’s default package manager? In most cases all you have to do launch it, select the program you want from a list of official packages, and click on whatever “install” button is next to it. In the event that the package you want isn’t on the list, you might be able to download it from the author’s web page into a folder on your computer. Then you can use your file browser to navigate to the download folder and double-click on the package file; that should launch the package manager and have it install the package.

IBM only provides the TSM client for Linux in a 64-bit flavor these days. If you do happen to know of a 32-bit version i’ll take it. Not sure how familiar you are with TSM though.

The vendor that staged the server didn’t install X on it and claims that installing X will give them room to no longer support any software on it including their own :rolleyes:, so i only have CLI to use. There are a couple dozen other RHEL servers that i have done in the past that actually worked fine with CLI but they came from a different vendor–at least they had the dependencies installed. I appreciate the help though, thanks.

is this system new enough to have the yum utility? If so, it can be used from the command line and can resolve dependencies automatically (assuming they’re resolvable.)

Yes, in the OP i mentioned how it didn’t seem to help.

Can you use an earlier version? There seem to be lots of third-party websites distributing version Version 6.2.2 for 32-bit. There are also blog posts explaining how to install version 6.x on 32-bit RHEL.

Hmmm… kinky. This could be the ticket! Thanks man, this is good news indeed.

Shameless self promotion of my Linux thread.