Lost in XP Hell

Yeah, another computer issues thread.

When booting my computer, XP Home hangs while attempting to log on. At “Loading Personal Settings” I get nothing. Mouse works and I can toggle caps.

A little background.

Over the weekend, I cleaned up a huge amount of spyware/malware using SpyBot, AdAware, LSPFix, and HijackThis. I did not delete any necessary files or screw up my registry to the best of my knowledge. If I deleted anything from HijackThis, I googled it first. My computer was performing beautifully for a few days. This is totally random.

I cannot boot into safe mode. After selecting my account or the admin account, it starts to load and hangs on the black screen that says SAFE MODE. Windows never fully loads.

I can load only the command prompt. I ran a chkdsk from the command prompt and found that my HD has no errors. Whew. It’s a laptop.

I have the system restore disk. It does not autorun. Despite my best efforts (lots of resets and crossed fingers), the computer will not boot from the CD. I even changed the boot order, and that predictably did nothing.

Booting XP with “Last known good configuration” also does nothing.

Googling has been unhelpful. Microsoft says that if my machine won’t boot from the restore disk, I need to call them for support. Yeah right.

I am not a techie but I have always been able to fix my own software and peripheral problems before. Hell, I haven’t been at my wit’s end since my idiot neighbor jammed index cards in the floppy drive of my C64.

Your insights would be immensely appreciated.

Even if you change the boot order, some BIOSes will still not automatically boot from CD; you may need to hold down a function key to make it happen (<F12> on my machines).

This is not a good situation to be in. It’s usually not possible to completely restore a computer that’s had lots of spyware/adare/viruses running on it, while leaving the “good” data intact. This is especially true of viruses. (Note that by “running on”, I mean the virus/whatever has actually infected the machine, not the case where a virus detection package notices it at the time of attack and prevents it).

Nevertheless, it’s not generally the case that a “cleaned” machine will run fine for a few days, then not at all, so this might be a red herring.

Luckily, you can get to the command prompt. Go to the Windows temp directory with “CD %TEMP%” if it will let you, otherwise you’ll need to navigate to it: “C:\Documents and Settings&lt;your username>\local settings emp” or “C:\Windows\Temp” or something similar (it depends on exactly what version of XP you’ve got, and whether you’ve ever changed certain preferences."

Once you’re in the temp directory, delete everything there. If this is a large number of files (more than 1000 or so), it can cause the hang at “Loading Personal Settings.” Try rebooting after deleting all of this.

No good? Alright, we’ll bump it up a notch. Can the command prompt see the Windows install CD? If so, CD to that disk, look for a “Setup.exe”, and run it. Hopefully, you’ll get to a screen that lets you “repair” an existing Windows installation. If not, and your only option is to “Restore” a disk to it’s shipping configuration, cancel out - some of these leave your data alone, some don’t. If you’ve got one available, an actual Windows XP install disk (as opposed to a restore disk) is better.

Still no good? Give me a little more information about “will not boot from the CD.” Does it try and fail, or not even try?

Thanks for your assistance.

I deleted the temp files. There were a surprising number of them, and some were very large. Alas, no results.

I neglected to mention earlier that I tried to run the setup program from the command prompt. It opens the installshield wizard and hangs after the progress bar fills up. Since I am human and expect different results from the same process, I tried again. Alas, no change.

When I boot the computer with the restore disk inserted, there is no change. I can access the drive without problem from the command prompt, but it does not boot from the disk on normal startup. It boots as it would normally.

I do not know if I need to hit any key to prompt it to boot from the disk instead. FWIW I have an HP Pavilion (I know, it was a great deal). That I can find out myself.

I do not have a real copy of XP. As if. All I have is the restore disk provided by HP.

When you change the boot order, is there an option for ‘CD-Rom only’, or for ‘CD-Rom, A’ or similar? Anything that would remove the hard drive from the boot sequence entirely? This would at least help to establish whether it’s the specific CD failing to boot, or the computer not attempting to boot it.

Or, try booting a CD of Damn Small Linux (a 50MB download, so feasible if the computer you’re currently on isn’t on dialup)

The only tried and true solution is to reinstall XP, even if you have to go out and buy a copy. If there is essential data on the current hard drive, then try to grab all files while in command line mode.

Ok, I took everything out of the boot order save the CD Rom drive. Now it boots from the OS disk. This is progress,

…which comes to a grinding halt since I do not have the slightest idea what the admin password is. I do not recall ever setting one.

Try just hitting enter - if no admin password was ever set, that should work

First thing I tried. Didn’t work. I can repair the existing install

Good god, connection is jumpy. I can repair an existing install by first selecting a clean install. This I have done before with previous computers with a minimum of data loss. Might as well hope for the best.

Worth trying, if you’re sure there’s nothing you can’t afford to lose.

FWIW, I did a clean install of XP on a drive that contained a broken version of 98 - I didn’t bother formatting, only converted to NTFS, and the old documents all showed up in the new My Documents location.

Wow, that was fortunate. There are plenty of documents that would be a royal pain in my ass if I lost, but no, nothing that would send me into the depths of despair. Unless my wife already wiped the CF card that contained our honeymoon pictures…

One step forward, two steps back. System is restored, but somehow I contracted a scorching case of PSGuard. No big deal, I can just download ewindo to kill it.

But now I cannot connect to the internet via my cable modem. Yeah, I already reset the modem and router and powered them back on in the right order.

Good lord, I have never been so close to buying a Mac.

Download and run WinsockFix, spyware removal will sometimes cause winsock problems.

I had a similar problem when Ad-Aware partially removed some spyware.

The deal was that the Run registry entry was trying to run the removed spyware on startup, and failing to find it, so it would “display” an error messagebox. But it couldn’t be seen, because it was still in the “Loading Settings” phase of startup. Thus, the situation you describe here.

I could simply hit Alt+Tab (or the Start key) to display the desktop. The fact that your mouse still worked sounds like you might have been able to as well. Unless you already tried that…

Sorry, I got distracted. It’s an HP machine? If you haven’t already, call 1-800-HP-INVENT and tell them your problem. The not booting from CD at startup is something they need to be able to help you with; don’t take “I don’t know” for an answer.