Magic Jack On Cordless Phone Stopped Working

Hey All

I unplugged the cable from the USB port but my phone still says, 'Connecting", but doesn’t give me a dial tone.

Magic Jack’s Tech Support is non-existent, so I’m asking anyone here if you may have had the same problem and how you fixed it?



On my cordless phones, “Connecting” is a message that the handset is connecting to the base station. It has nothing to do with the connection between the phone itself, and the outside lines.

Can you plug in a traditional phone? If it works, the problem is with the cordless, not the service.

Thanks, butler1850, we’ll try that!


Thanks, butler1850!!!:):):):slight_smile:

We switched out the phones and the new cordless works now!

Thanks, Buddy!


Just another update: Apparently Magic Jack is a whore for telemarketers, right?

I mean, I’m in the computer, enter something about cycling, and the next thing I know there’s a message on the phone from Bicyling magazine.



I’m glad to hear my suggestion worked! :smiley:

As for telemarketers, you can put your inbound number on the “Do not call list,” right? If you’ve not entered it, it’s the same marketing whore that a brand new POTS (traditional line) would be.

Actually, that seems like an interesting idea, and may explain how this company call sell the service for twenty bucks a year. The Wikipedia article on the product quotes the EULA as permitting onscreen ads (see below). Perhaps the EULA also permits them to resell your number to telemarketers?

“You also understand and agree that use of the magicJack device and Software will include advertisements and that these advertisements are necessary for the magicJack device to work … Our computers may analyze the phone numbers you call in order to improve the relevance of the ads.”