midi interface works in DOS but not windows?

Please help me, this is driving me NUTS!!

I’m trying to set up my laptop for midi sequencing plus a little audio.

I have an opcode studio 64x connected to my 1 year old laptop via the 9-pin serial port. I ran the opcode setup and ran the diagnostic, which runs in the DOS environment. Every test (play scales on all ports, show midi input data, etc.) works fine, but when I go back to the windows (98se) environment and start the configuration, I keep getting “64x not found” and “check driver and restart” type messsages. I checked the system folder and the driver is there, the opcode disk indicates it’s good for windows 98. Is there a big enough difference between 98 and 98se that would make the driver not work? I ran the add new hardware thing but the serial port wasn’t mentioned specifically, and when I let the add hardware function search the diskette for the COM1 (serial?) and LPT (parallel?) port drivers, it didn’t find anything, so I don’t think this is the direction to head. What do you think I should do next? I messed around with the MIDI settings in the multimedia control panel also - that didn’t seem to do anything. I don’t really feel like springing for a USB midi interface.

This was sinking fast. Someone that knows something about such stuff, throw us a life vest.

I’m not an expert, but …

I have windows 98, and I’m assuming that 98se is similar enough, so

  1. Under <Start><Settings><Control Panel><System><Device Manager> there should be a section called <Ports Com & LPT>. Is your serial port listed? Does windows think it’s working properly? (i.e. under device status, windows should say, explicitly, ‘this device is working properly’)

  2. There’s probably also a section called ‘sound, video and game controllers’. Is your midi device listed there? Is it working properly?

If the answer to any of the above is no, you’ve found the problem.

What happens if you try and re-install the windows drivers for the serial port and 64x? (i.e. physically remove them from the system, delete from control panel and start again).

Feel free to email me if you don’t want to continue the discussion on SDMB…

Thanks for the life vest, kniz

I’ve removed/installed the driver two times, mucked around with the midi settings (all the 64x ports come up), the serial port is “working properly” according to the device manager. The computer is reading and sending midi signals, I just can’t seem to break through the windows barrier. AARRGH! The 64x is a 4 in/6 out interface so to replace it would mean another $350 or so and I’m not much inclined to do that.

perhaps this is a sinking ship after all

Under the Device Manager, check the section called “Other Devices”. If there is anything listed as ‘unknown device’ then remove it and try the card again. Often when windows has a device listed twice in device manager it will not work at all.

Also, I assume you are using the latest drivers from the manufacturers website? If not, try there.