Mounting Drives in Solaris 10

Possibly not the best place to ask, I know, but the quickest and it’s a fairly general question.

Anyway, my power supply went this weekend. I decide that as long as I had to replace it, I might as well pick up those other parts I’ve been wanting–more RAM, a DVD burner, a new hard drive to replace one I’ve currently got in there (I’m slowly transitioning all my hard drives to SATA), and one of those multi-card readers that run off a USB header. Anyway, I somehow managed to screw up my Windows XP install in the process, though I believe the hard drives with actual data on them (the OS gets its own hard drive for exactly this sort of problem) are okay. So I’m hoping to copy over the data from the old hard drive to the new one I’m replacing it with, reinstall Windows, and go through the long process of reinstalling everything needed. At the same time, I’ve been meaning to play around with this copy of Solaris 10 I got a while back. Well, anyway, the reinstall of Windows hasn’t worked well–I’m thinking it’s a driver error, possibly the video card. So I thought I’d go ahead, install Solaris on the part of the drive I set aside for it, copy the hard drive involved, install the final configuration of hardware I want, and reinstall Windows and hope I can pin down the error then. But I’m stuck at the copy hard drive step, because I can’t figure out how to mount the hard drives in Solaris.

Anyway, the hard drive with the data is a 120 gig EIDE on primary slave while the empty hard drive I want to copy to is a 160 gig SATA on something like tertiary IDE according to the BIOS. The 120-gig is formatted NTFS and the 160-gig is partitioned but I’m not sure I’ve managed to format it yet. FAT32 can’t handle a single drive of that size and I’m not sure I managed to get it formatted NTFS during the Windows install process. I know that Unix operating systems have trouble with NTFS. In any case, I’m still not used to the Unix command line and am not sure what the actual command structure is past “mount”. Would I be better off doing this from a Ubuntu live CD or the like, and can anyone give me a simple way to mount those drives?

As far as I know, Solaris 10 doesn’t do NTFS out of the box, you’ll need to install something like mount-ntfs. Not sure what you mean about “actual command structure,” do you mean, what is the syntax of the mount command?

mount -t fstype device /path/to/mount/point

I’ve never used the ntfs package on Solaris but I imagine fstype will be “ntfs”. device is the device file representing the partition you want to mount, e.g., ‘/dev/hdb1’. the path is whatever directory you create as the mount point, e.g., /mnt/ntfs_part

I do feel like I should add however, if your data is very valuable to you, mucking about with it using what really are experimental tools in an environment you’re not totally comfortable in might not be the best idea.

Yeah, sorry, the syntax. And I found that too, but they’re saying it’s read-only, so that might not work unless I partition the 160-gig into something small enough for FAT32 to handle and remove the partitions using Partition Magic or the like later. So there’s no really good way to write NTFS?

And yes, I know the risks. I’m going to try reinstalling Windows first and see if I can do it in there. But I need some sort of backup plan. In any case, this isn’t the really important data, just where I install all the programs, so at most I’d lose saved game files and the like.

I’ve had mixed experiences using filesystem drivers in O/S’s that didn’t support them out of the box (both directions, e.g., ext2 in windows). Sometimes they appeared to work, but then were partially unreadable by the host system later. Since you seem to be familiar with them, I think the newer Linux live-cd distros do come with ntfs modules that allow write. It’s actually been a while since I’ve used Solaris heavily but historically, and IME, it hasn’t intersected well with the windows world. So sorry, I can’t really offer any good advice about writing to ntfs under Solaris.

Another possibility is, since it’s just your data drive, and if you’re willing to use a partition resizing tool afterwards, you can just copy the whole drive raw with the dd command. Doing it this way the filesystem becomes irrelevant (you don’t even mount the devices, you just block copy from one to the other). You should be able to get away with doing a simple dd if=/dev/hdb of=/dev/hdc (or whatever the lettering is in your system). If you’re going to try this, be very, very careful not to write to the wrong device. It would be a matter of a single keystroke.

After it’s done you will have to fix the new partition table to make the copied partition take up the whole drive.

Actually, this isn’t correct. The FAT32 format can handle that size (and up to 2TB); it’s just Microsoft’s formatting tool that can’t format FAT32 larger than 32GB. You should be able to format it as FAT32 using a non-Windows tool (presumably including the Solaris formatter, though I’m not familiar with it).

I’d personally much rather have my data drives in FAT format for easy mounting everywhere, but that’s just MHO.

Well, if that works, I’ve give it a shot. I normally use NTFS because I use the encryption features, but if I can format it in Solaris and transfer the data, I can always convert to NTFS later.