MP3 Encoder help

Hi Folks,

Over the last couple of days i’ve encoded about 20 of my CD’s to 192 bitrate MP3’s using Apple iTunes. I really like the fact that iTunes automatically looks up the Artist, Album, and Track info, and also the ease of “one-click” importing of my albums.

However, upon listening to the imported albums, the quality of Apple’s encoder is … at best… “lacking”. On many tracks, I get distortion and what could best be described as static, about 4-8 seconds into the track, lasting about 2-3 seconds. Even if I transfer the mp3 file to another machine/player, it is still there. This is not acceptable.

I’ve got a couple of questions…

  1. Has anyone ran into this issue with iTunes?

  2. What are you using to encode your albums?

Thanks alot!


I haven’t done it in a while, but I always used AudioGrabber with the LAME MP3 codec.

Of course I am no audiophile. I couldn’t tell a good MP3 from a bad one even if you ported it through my braces.

Oh, AudioGrabber is shareware. Limited capabilities if you don’t pay but a fine little program for $20.

I believe there’s a LAME MP3 encoder for iTunes as well. But then, I think 160 bps MP3s are just fine, so I’m obviously not one to consult for audiophile references.

You may also want to use iTunes’ AAC encoder, since it gives better quality than MP3s at the same bitrate.

I use Lame for mp3’s. These days, though, I encode everything in Ogg Vorbis. The sound quality difference between an ogg file and an mp3 file of the same size can be rather startling.

One Click importing? I know it’s in quotes up there but maybe there’s a short-cut I’m missing. Right now, I’m sticking a CD in the drive, then highlighting the tracks in iTunes, click and hold with the mouse, drag 'em to the library, and then move 'em to my iPod. (I’ve never had a problem with doing that).

It sounds like you’re getting bit errors from your cdrom drive.

Are you on a Mac or Windows?

The Mac version has a checkbox in the “importing” tab in the preferences that turns on error correction. I’m not sure about the windows version, but I would assume it would have something similar.

In the preferences, there’s an option for “What to do when a CD is inserted.” One of the choices is to automatically rip the tracks and eject the disc – great for when you’ve got a whole stack to do…

I use the dbPoweramp music converter. It’s freeware, uses the LAME encoder, and, like iTunes, has a CD lookup function. I know that some people swear by CDex, which also uses LAME and is apparently very good.

Of course, if buckgully is right and the errors are coming from your CD ROM drive, it won’t make too much difference which ripping tool you use.

Thanks for the info, all. I think that it is the CD rom drive on my laptop that is the problem. It appears to work fine on my other machine.

If you put a cd into the drive, you can just click on the button in the upper-right hand corner of the itunes window and it’ll suck the cd into your collection…

Egads! That’s even easier. Thanks for the tip! :smiley:

If you’re really looking for disgustingly high quality rips and hard drive space isn’t an object, then try following these directions to create “Uberized” rips. As stupid and 1337 as that overused word may be, the MP3s you get with that process are gorgeous. They’re legitimately good enough to be called “archival” copies. The process uses the LAME encoder, Exact Audio Copy (EAC) software, and predefined configuration files. Remember, sharing MP3s of copyrighted material to which you don’t own the copyright, even if they’re ripped from CDs you purchased, is illegal.

If you’re having problems with your CD drive, consider (in order of convenience):

  • ripping audio on a different machine altogether
  • ripping at a lower speed (1x or 2x)
  • turning off any programs that “thrash” the hard drive while you rip
  • downloading the latest drivers and firmware for your CD-ROM drive
  • getting a bigger power supply or better drive