MS Word problem: my doc keeps growing and growing...

I put together a simple contract using word, based off an old template of a contract I did like 2 years ago. I cut and pasted elements from probably 3 different contracts. It’s pretty much all text: no diagrams, no pictures, no cells, nothing. Though it’s only 44 pages, the final tally in size came out to be 2 MB! After a couple of revisions back and forth between 3 different entities, it is now 15 MB! :eek: Why is this happenning? It seems everytime that I save it, it pretty much copies itself in the save. I’m sure I’m not describing that correctly, but that what it looks like it’s doing. Any help here? Thanks in advance.

This happened to me once too, but the only explanation I have is “because Word is an asshole.” I also would appreciate a better answer.

Is there a lot of formatting? Can you C&P it into WordPad and back? That should make it somewhat smaller. Or just try copying it all into a new Word doc and see how big that one is.

I had that happen before when updating important documents and reports. It involved older documents saved under a previous version. I found everytime I saved the file it doubled in size. Starting with a new document and typing the paragraph in, I had a small file that didn’t double.

Open a new document from the menu. Save it. Open the large document and “select all” and “copy” all 44 pages. Go to the new document and from the menu use “paste special” and choose “paste unformatted text”. Save the new file and check the size. Save the new file under a new name again and check the size. Has it stopped doubling in size? Close the files and “Word”. Reload one of the new files add one charater to the document and save it again. Did it double this time? I don’t have a suggestion other than this.

I’m not sure Word does this, but other programs often sacrifice saving speed for size if they don’t have to re-configure the data before they save it (the “save” function). “Save As” usually re-structures the file from scratch to better use space. Try that option.

Cutting and pasting into a fresh document with “unformatted text” will solve your problem, but then you’ll have to reformat everything from scratch.

Word is a ass.

This happened to me back in 2000. Try using the View menu and turning on everything that’s normally hidden. You may have all manner of unprinting stuff embedded in there.

Another disk-eating trick Word will sometimes do is to save formatting instruction repetitively, like before every paragraph.

By the way, the “unformatted text” trick will make every line end with a end-of-line break where it appears on screen. Which means if you add one word, you get a line wrap with one or two words on the
next line.

A better trick is to save in Rich Text Format, copy and paste, then reformat with your Word-specific characteristics. This preserves much but not all of the Word formatting, and will often get rid of garbage.

I haven’t noticed this in Word personally, but I have noticed it in another software app I use a lot. As you keep changing and saving it, the file size steadily grows. Why? Dunno. But if I save it under a different name, the new file is back down to where it should be.

Try saving the document as, say, test.doc and see if the file is smaller.

Just a thought, probably won’t work, but it might and is quick to test.

Microsoft Word saves every single tiny change you’ve made to the document, unless you tell it not to. I’m not sure what’s the point of this, since I’ve never figured out how to actually retrieve those changes.

Here’s how to fix it – Go to Tools -> Options -> Save and click on “Allow Fast Saves”.

Disable “fast saves” as that effectively just nails a copy of the full document onto the end of the file, rather than saving just the one version.

“Track changes” can also lead to mushrooming files as all of the changes are saved in the file.

That’s great to know. I never figured out the difference between fast save and regular save.

I think the reason may be that you’ve enabled “track changes” without enabling “show tracked changes” so that word will save every modifcation you do to a file.

You could indeed have Track Changes turned on but not be seeing them. But that won’t cause the rate of growth described here.

Another option that Word provides is versioning. See Help, Document Versions. I used this exactly once until I saw how much space it chews up.

If you have that box checked, uncheck it.

I have had some docs that I at some point used ‘track changes’ on and forgotten about get HUGE after 10 drafts or so. Go in and see if it asks you to approve all changes.