Need Fallout 3/Windows 7 help

OK, let’s see if I can word this well enough so that I get my point across… just FTR, I’ve looked elsewhere and tried other solutions, which I will do my best to relate below.

I recently bought the Fallout 3 Game Of The Year edition for my laptop. The install went off without a hitch for the most part, but now that I’ve got it installed I can’t even get through the first story sequence without the game freezing up. Just after my character is born, there is some dialog between the mother and father characters, and it’s during this time that you get to pick what your character will look like. In about a half dozen attempts, I’ve only made it through that process once before the game froze; other times it’ll freeze up before the father even gets one word in, and I’ve gotten through the naming step one other time. The background noise in the scene (mostly just a heart rate monitor) keeps playing after it freezes up, but the only way I’ve found to get out of the game after that is to Ctrl-Alt-Del my way to the Task Manager and end the application.
I first contacted Bethesda Softworks, the developer that made the game, and they asked me for my Direct X dialog (DXdiag) before suggesting that I try to run the program in Compatibility Mode. First problem with this is that I wasn’t entirely sure which file to run in Compatibility Mode. I ended up trying to run the Fallout3.exe file on my C: drive in Vista SP2 mode. Didn’t work.
Next I searched through the Fallout forums. I tried the solution listed here. Assuming I did everything right, the end result was the same freezing I experienced before.
After that, I’m honestly a little stumped. I’m not computer illiterate by any means, but I’m hesitant to do any mods or rewriting codes or any other crazy stuff that some of the users are doing. That and most of the users that discussed freezing or CTD issues on Fallout 3 at least got to play the game before something went wrong. Nobody seems to have had the exact issue I’ve had and posted about it that I can find.
It might be helpful to list my laptop’s specs, so I’ll do that below, but according to the Systems Requirement Lab’s Can You Run It? program, I should be able to play this game except for having Windows 7, which isn’t officially supported. BethSoft said as much as well.

Operating System: Windows 7 Home Premium 64-bit
Processor: Intel Core i5 M430 (2.27 GHz)… I thought I had a quad core processor, which is why I tried the tip in the Fallout forums above, but cnet says it’s only a dual-core.
Memory: 4 GB RAM
Video Card: NVIDIA GeForce 310M (512 MB)
Direct X 11

I think that’s all the relevant info. Any help would be greatly appreciated, as always. Last note, though: I’m leaving for Afghanistan tomorrow, so I may not be able to check the SDMB for a while. I’ll get to any requests for more info when I can, and if anyone has a fix to try, I’ll report when I can on its effectiveness. Thanks again.

My first option would be to try a different version of the video driver. First make sure you’ve got the latest version. If that doesn’t help, fall back a version or three. Beyond that, I can’t help much without hands on.

Does the laptop feel hot during gameplay? Is it perhaps overheating? Are you playing on a level surface with nothing blocking the fans?

First, did you install the release patch?

Second, you said laptop? Make sure you are on high performance, and plugged in. Fallout 3 will work on Win7, without compatibility mode. It still crashes so if you get it to run, don’t forget to save, save, save.

You also will want to familiarize yourself with the console “cheats” commands. I enjoyed the game immensely, but I would never have completed it without “cheating” when the NPC I needed to speak to disappeared and could not be found.

If you find you must use compatibility mode, xp service pack 2 with administrator privileges would be the first pick.

Good luck and Happy Gaming!

Well, I was finally able to download and install drivers after being in Afghanistan for a few weeks (hard to find that kind of bandwidth around here), but I installed the latest driver from the nVidia and that seems to have fixed the problem. I’ll try the release patch later if I run into any more problems, but that’ll be more difficult thanks to the restrictions the Net Nazis have set up on the network here in Afghanistan. Thanks for your help.

Moving to the Game Room from GQ.

The OP has informed me that despite his last post the problem has cropped up again.

General Questions Moderator

I got this game for Christmas, and the conclusion I’ve come to is that it is the most buggy piece of excrement I have ever installed on my computer. It’s a good thing that it’s a fun game or I would have taken the DVDs out to the shooting range and used them for target practice.

If you installed the DLC content on the second DVD, that also installs the 1.7 patch, IIRC. That may save you some download time.

The only other advice I have is just to keep searching the net. The problem seems to be not just that the game crashes, but that there are so many different things that can make the game crash. Updating my sound and video drivers helped. Turning off the hardware acceleration on my sound card helped. I did the ini file tweak that was mentioned in the OP but it didn’t make any difference on my system. I turned off shadows and played around with the video settings, which helped. Some folks have had success running in windowed mode, with the window set to the size of the screen so that it looks like it is in full screen mode. That didn’t help me at all.

Are you still getting crashes during the character configuration, or are you past that and getting random crashes now? From what I’ve seen while hunting down my crashes, both of these are quite common.

The game also conflicts with many popular codec packs. If you search the net you’ll find ways around some of these conflicts.

Maybe it’s Nvidia that’s the issue? My (fairly weaksauce) laptop has ATI video, and I didn’t have any crashing problems in either Win7 or Vista. No more than I did on the 360 anyway.

First, thank you, Colibri.
engineer_comp_geek, I installed all the DLC on the second disc, so I’m trying to confirm right now that it installs the patch for me. Otherwise, I might not be able to get it till after I leave Afghanistan, because all gaming websites are web-filtered here. So far, I’ve been able to get past the character creation bit and even past the sequence where you take the GOAT, but it’s taken me several attempts to get that far, and it’ll always freeze up in fairly short order. I’ll try playing around with my settings and report back. I’m getting pretty frustrated with it, too, BTW.
TBG, I’m also trying to figure out where my video card fits into NVIDIA’s hierarchy, and what its specs are compared to other cards. I was under the impression that it was fairly high up in the laptop rank structure, but it’s not listed on Fallout 3’s list of officially supported cards. This might be the problem, but we’ll see.
There’s a LOT of info out there when you Google something like “windows 7 fallout 3 freeze,” but I’ve just thought to try “nvidia geforce 310m fallout 3,” so I’ll keep trying stuff till I get something to work. One problem I’ve been running into is that people in computer forums will say, “Make sure you’ve done X, Y, and Z,” and I won’t have any idea how to do any of them! Not computer savvy enough…

Go to the directory where you installed Fallout, right click on fallout3.exe and select properties, then click on the version tab. That will tell you which version you have installed.

Update: I followed engineer_comp_geek’s instructions and found that I am running version In addition, I’ve now turned the “Detail” down to “Low” and I’m still getting the damn freezing issue! There’s no way to make the game any less graphically intense, and it still freezes. BethSoft’s latest suggestion is to close all background applications, like I couldn’t have figured that out, and they were also kind enough to direct me to, which I take to mean they have no more suggestions for me.
I’ve come to the conclusion that it must be a problem with my graphics card. I mentioned above that I thought it was a perfectly capable of playing a 2-year-old game, but according to this site, it’s an “entry level laptop graphics card.” sigh So I don’t know if I’ll ever get this thing to run… not like it’s the only $30 I’ve ever wasted, but this is one of the things I hate about PC gaming. If I buy a game for my Wii, I can be pretty friggin’ sure that it’ll run with few or no problems on my Wii. On a PC, even if I do my homework and do my best to make sure, I still end up with crap like this. :mad:

What version is your Nvidia driver? Googling around seems to show several driver versions for Nvidia just don’t like Fallout. I know you said upthread you’d installed the latest, but it’s entirely possible there could be some older version that was better, or an unsupported beta that’s better.

Right click desktop, go to NVidea Control Panel, Click Manage 3D Settings, look for Maximum Pre-Rendered Frames and set to 1, if nothing, set to 0.

I have no idea if this has anything to do with your problem but it stopped GTA IV from freezing for me and others.

Also just wanted to make sure you have the correct driver, is this the exact one you downloaded?

'Nother update: I took Hennessy’s suggestion regarding the NVIDIA Control Panel… changing this setting to 1 got me almost all the way out of the Vault before it started freezing, and changing it to 0 has gotten me all the way out to Megaton, although I still had to restart the game a couple times to get that far, and I took a detour through Sunnyvale (the town between the Vault and Megaton).
TBG, do you know how I would go about getting older versions of my video card’s driver? This is something I’m willing to look into, but I just have no idea how to do it.
Hennessy, I’ve got a slightly older version of that driver… I downloaded it in late December, I think, so I know I don’t have that one since it was released last month.

I just want to make sure I say thank you to all of you who are willing to help me out through every little step here. If anyone is still willing to offer suggestions, I’ll be willing to try them out.

You may have found this already but…

Someone else said they got it to work by changing “iNumHWThreads=2” into “iNumHWThreads=1”

I don’t understand what he is doing but it may be worth trying but be sure to copy and paste the fallout.ini onto your desktop before you edit it. If it doesn’t work, just paste the copied original one back into the folder and overwrite. It is a long thread but that just makes it more possible to find a cure…

Finally, if your game is not legit then give me a PM

Thanks! I will have to try this out… anything’s worth a shot at this point. I just logged on here to see if this thread had been updated after trying to play a little bit and having to restart a half dozen times in an hour.
Some of these users have very similar specs to mine, so I hope there will be a solution that works somewhere in there.
Thanks again.

Damn! Another failure. Well, try, try again.

They’re available right on Nvidia’s website. There’s a “download drivers” heading and if you hover on it the 2nd option down is “beta and archived drivers”

This link should also take you right there, then you just plug in your system’s info and it will show you all the old drivers for your setup

OK, I think I’m just about done bugging everybody about this and bumping this thread back up to the top of The Game Room page, but I have one more question: If I decide to stop worrying about the copy of this game that I already have and download it from Steam instead (I should be able to sell my DVD no problem), will that copy have the same problems I’m getting now? Has anybody here bought Fallout 3 from Steam and played it on a Win7 computer? I’m pretty sure Win7 isn’t my problem, but getting help from Steam might be a step in the right direction.

BTW, thank you, TBG.

I really don’t think Steam will make a difference.