NetWork card disappeared.

Win XP pro

In the course of trying to reinstall a driver for a DVD, I seemed to have lost my network card.

Under Computer>properties>hardware>device manager. Nothing is listed as a network adaptor.

I have reinstalled the driver for the card from the disk that came with the machined (dell 4700). Is there some other troubleshooting I can do?

A little bit more info, and a bump.

As I said, the driver seems to install fine. This is the driver that came with the machine.

Ping machinename responds with nothing lost. So I assume something is working.

Oh, thats a ping to itself. It’s not on a network.

I guess I’m looking for some way to tell if the card is fried, or something else is going on.

If you can ping it and ping from it, then it’s working fine. In your case the former is a little problematic. :slight_smile:

Can you ping
Can you ping your DSL modem?
Can you ping [noparse][/noparse]?

Trying reinstalling the chipset drivers for your motherboard.

So you think the NIC is OK if I get a response pinging the machine from itself? That’s what I think.


Don’t have DSL. I’m on a DirecWay sat dish (or was). It is an external modem. And I have a router hooked up. Thus I can still get on from my NetBook. Modem and dish are OK then. i’ve tried taking the router out of the loop, but the Desk top still does not see its NIC. It’s is not found under Windows hardware, and set up with the DirecWay software says it does not exist.

But I can ping it.

Can you ping [noparse][/noparse]?
Nope. Internet is down as my modem can’t find the NIC.

Done. No change.

Through IE >tools>Diagnose Network problems…

I think the card might have failed… But I can ping it. That’s what I don’t understand.

It’s OK if you can get a response to a ping from another computer. If you ping yourself then the NIC isn’t in the equation at all.

One way to try and see whether the NIC is ok would be to try booting a Linux Live CD on it. If Linux can find the NIC, then the problem is with Windows. If Linux can’t find the NIC, that’s evidence that the NIC may have died(but not completely conclusive – Linux won’t necessary work on all laptops, for example)

Have you tried deinstalling the DVD driver that seemed to cause the issue?

I’ll give Linux a try. Though I am a bit restricted on bandwidth. I’m hoping it’s pretty small.

Back to UNIX eh? It’s been years.

It’ll be a few hours before I can attempt that. I’m rather surprised that there isn’t a simpler test to see if the NIC is OK.

Pinging shows that the TCP stack is installed and working - this is the TCP loopback address. Can you ping your router? One of your other PCs?

If you bring up a command prompt and do ipconfig /all, is a NIC listed?

I’m guessing that you cannot ping outside your machine.

Is there anything in the event logs?

Do you see the NIC if you elect to Show Hidden Devices in Device Manager?

Ipconfig /all
returns –

Windows IP Configuration.

That’s it. No IP’s, no numbers no nothing except the three words above. I’m familiar with the command. It returns what I would expect on my NetBook.

I’m stunned that there is a view option in the device manager to hide ANYTHING. I do now see –

Network adapters >
>Direct Parallel
>Intel PRO/100 VE Network Connection –Packet Scheduler Miniport
>WAN Miniport (IP)
>WAN Miniport (IP) Packet Scheduler Miniport
>WAN Miniport (L2TP)
>WAN Miniport (PPPOE)
>WAN Miniport (PPTP)

Not sure what the hell all that means, other than it seems to think it’s on a Wide Area Network. It is not. It has never been. It’s never been on a network.
As per the device manager, everything is enabled and working properly.

if it is a desktop open the case and remove the nic. Reboot then put the nic back in. A different slot wouldnt hurt either. If that doesnt work I would assume a faulty nic and buy another one. They do go ALL the time. I carry 3 or 4 with me, I suspect the quality of the consumer grade ones are p…poor. What is a nic card now, 15 bucks? just replace it.

The loopback is virtual. Pinging doesnt really mean anything.

In hardware manager are there any unrecognized devices? You’ll see something like this:


Look for yellow question marks or exclamation points in device manager. It may be hiding there.

Not true. It demonstrates that the TCP stack is working.