Networking XP to Vista: HELP!

I’ve got a Windows networking problem that threatens to make me hit something.

Here’s the topography: Vista desktop connected by Ethernet to router. XP notebook connected via 802.11g to router.

Both computers are in the same workgroup. There’s a USB printer connected to the Vista box.

The Vista box can see the XP box, read/write files and generally work correctly.

The XP box sees the Vista PC, but when trying to connect, I get a “Logon failure: the user does not have the necessary permissions.” Can’t print, either.

The Vista box won’t let me disable password-protected sharing at all, but file/print sharing is enabled.


I recently solved the exact same problem. Try temporarily turning off firewalls on both machines, then add printer from network on the laptop. Hope this helps.


Right click whatever it is you want to share (printer, specific directory, c drive) go to sharing. Depending on what exactly you are sharing, either on that screen or under the advanced sharing screen you’ll find something about WHO you want to share with. Hit the drop down box, pick either ALL or EVERYONE and then click add. That selection should show up in the box below the drop down box. Now, on the new entry change right column drop down box to “CO-OWNER” and then Okay your way back out. Give that a try.

Tried it and still no luck.

I’m starting to wonder if Microsoft gimped the networking features in Vista El Cheapo Edition so they could sucker people into paying for one of the other versions.

No, it’s just a pain to get them to play nice together, no matter what the version. Ohh, one more thing (assuming you set the permissions). Go to control panel, network and sharing center, and change File sharing and printer sharing to ON, turn OFF password protected sharing and try that. If it still doesn’t work, turn on public folder sharing and see if you can at least see the public folder from other computers (but do that as a last resort).

That’s the thing: it won’t let me turn password-protected sharing off. Every time I click the “off” radio button and hit Apply, it stays on. I’ve tried turning the Guest account on and off, setting a password, everything, but I still can’t turn it off.

If I could find a registry hack to disable it, I’d do that, but I haven’t found one yet.

Are you logged on as an admin?

Which version of Vista do you have?

In the meantime, when you try to the Vista box, use the Connect As Another User option and explicitly specify an account on the Vista box. You’ll need to prefix the account name with the computer name like this: VistaBoxName\VistaUserName.

Home Basic, I believe. Came preinstalled.

OK, update:

I got the LLDT responder installed on the XP machine (thought it was already installed until I went looking for it.)

However, the Vista box still says “cannot place this device on the map” when I look at the Network Map. Any ideas for how to fix that? I’m pretty sure most of my problems will be cleared up when I get that nailed down.

I’ve a nasty feeling that Vista Home Basic is thoroughly borked when it comes to networking.