New 'Net connection/can't reach certain sites

I have just gotten connected to the local fiber optic Internet line! Fast, fast, fast!

But there’s a problem: I can’t connect to a number of sites. Specifically, I can’t access:



www.comics.com

And most of Yahoo’s services. In particular, I can’t access the server that hosts Yahoo’s login system. Which means that I can’t manage my Fantasy Baseball teams, I can’t manage or post to my Yahoo! Groups, I can’t read my Yahoo Mail accounts, etc.

I also seem unable to connect to some server(s) that serves streaming content; some sites load, but when I click on video links, the video won’t load.

Here’s my connection’s hardware setup:

Fiber optic line into the house
Line goes into a D-Link ethernet router, which also serves as a DHCP server
Two lines out of the router - one to my roommate’s PC, the other to my Mac

I first thought the problem with accessing these sites was with my Mac, but it turns out I can’t reach those sites from my roommate’s computer either. So the problem is upstream somewhere.

Somebody suggested to me that this sounds like a DNS cache problem. I assume that the DNS cache would reside on my ISP’s DNS server. However…

When the tech was here hooking us up, he had me trying to configure my PPPoE, saying that was the protocol to use. It didn’t work, though, and he unfortunately couldn’t stay any later to figure it out. I told him that my stepfather and mom have the same fiber optic setup, and Macintosh computers just like me, and that I could call my stepdad for help.

From my stepdad, I found out that I should use my DHCP settings, just like I had done with the DSL connection I had at my previous residence. Sure enough, using DHCP got me up and running.

But I can’t access the sites I mentioned. It has occured to me that, while trying unsuccessfully to make PPPoE work, I tested the connection by clicking my links to apple.com, and yahoo.com

So is it possible that the DNS cache is stored in the router? That doesn’t seem likely to me, but it would make a certain kind of sense if my early, unsuccessful attempts to reach those sites got logged in the cache as being nonexistent. So now when I attempt to reach those sites, my connection is going to that cache instead of to the proper server…

I can still access these sites if I use the dialup AOL account I was using temporarily while waiting to get the fiber optic connection. I can also reach the sites if I go through a proxy, such as anonymizer.com. So it’s clearly a problem with my connection through my ISP.

I have already sent an e-mail to my ISP’s support address, but I have yet to hear back from them. In the meantime, does anybody have any suggestions for things I might be able to do from here to fix this? It’s absolutely vital that I be able to access www.apple.com , because I need to download software updates.

Well, good on your step-dad – PPPoE sounded kinda bizarre to me.

I had a similar problem with my cable connection. Eventually, I powered down everything, disconnected the computer from the cable modem, waited several minutes, powered the modem up, reconnected the computer, and powered it up. Worked fine after that – just needed to convince the modem to reboot.

I don’t know if your router has a DNS cache; some do, but I don’t know much about which or why. But rebooting ought to help.

Hmmm… I am able to administer the router from my computer, and I’ve rebooted the router a few times now. I’ll try unplugging it again for a while, and see what happens.

Thanks :slight_smile:

What is the IP response when you try to ping one of these URLs? I recently dealt with a customer that couldn’t surf to antivirus sites – it turned out that her HOSTS file had been overwritten so that things like www.symantec.com were pointed at 127.0.0.1

I can successfully ping apple.com and login.yahoo.com, yet I still can’t access them via my browsers. I suspect that these pages might by assembled from objects residing on different servers, and that it’s those other servers I’m not able to access.

I was unsuccessful pinging comics.com and mac.com.

Where would I find my HOSTS file on a Mac OS X machine? (it’s based upon BSD Unix).

Oh - since my roommate’s computer also cannot get to these sites, I’m sure the problem isn’t with my own computer.

On a *nix box, HOSTS should be in /etc or /etc/network (and in many cases, both, as one is symbolically linked to the other)

What was the IP address returned in the successful cases? In this case, we’re more worried about resolution than RTT.

www.apple.com.akadns.net [17.254.0.91
www.yahoo.akadns.net [66.94.230.35
www.comics.com [65.114.4.69]
www.mac.com [17.250.248.32]

Hve you tried a 3rd party DNS server? I often have people try the one at 217.17.128.1 (ns1.frii.com)