No sound on a Winbox—how to diagnose

Well, here I am at my wit’s end (which isn’t really saying much, as I’m somewhat witless to begin with). I get no sound from my PC and am out of ideas as to how to find the cause of the problem.

The problem seems to have arisen a few months ago on moving day (!) but stranger coincidences have happened. Other than this issue, the PC is working flawlessly. It was playing sound (mp3 & CD) up to the point where I packed the system up and brought it to our new home. Within a day the machine was unpacked and everything except sound worked fine. Well before moving day and afterwards, no new software was installed and no changes to the system were made.

Here is the hardware information:
Motherboard: Epox EP-9NPAJ / 9NPA+ Ultra
On board sound: Realtek AC97, ALC850
CPU: AMD 64 3700+ (San Diego)

Here, in no particular order, are the things I’ve done/checked so far:

[li]Winamp, system sounds, etc. play no sound. They look like they are playing, but no sound comes from the speakers[/li][li]System is not muted, either in the system tray, when opening up volume control (and in advanced), in control panel, or in any of the applications I’ve been running[/li][li]Opened the case and looked for loose connections[/li][li]Speakers were checked on a CD player, they work fine[/li][li]Alternate speakers (Headphones, checked on a CD player as well) do not work[/li][li]I have no alternate sound card to try in the machine[/li][li]Nothing to note in device manager, no flags and all is supposedly working properly[/li][li]DirextX diagnostics do not make sound[/li][li]Reinstalled the drivers from the original install CD that came with the motherboard[/li][li]Ran the Realtek “Sound Effect” sound manager[list][/li][li]Its tests (i.e. speaker configuration, sound effects), appear to play but I get no sound[/li][li]When I run ‘connection sensor,’ it properly identifies either powered speakers or headphones on the line-out connector (green), but it also tells me to check ‘line-in,’ though there is nothing plugged in there. I have checked the connector for detritus, but there is nothing lodged in there[/li][li]When running ‘connection sensor,’ I hear a couple clicks from the speakers. This also happened when I first built the system, and sound was working properly.[/ul] [/li][li]I get no sound in Safe Mode (but didn’t expect any—apparently no sound drivers are loaded)[/li][li]I rebooted, disabled the onboard audio device in BIOS, had no audio present (i.e. not present in control panel, volume sliders grayed out, etc.), rebooted and turned it back on in BIOS—everything was present again, but still no sound [/li][/list]
So… now what? What else is there to check? Where do I go for from here?
Quietly yours,


Here is the order in which I would troubleshoot this problem. You may have already done some of these, so please bear with me.

  1. Make sure speakers are plugged into power source
  2. Make sure speakers are plugged into correct output on sound card.
  3. See if I get sound when playing an audio CD.
  4. See if I get sound when playing a .wav file.
  5. See if a .mid file will play
  6. Go to “Sounds and Audio Devices” and make sure it is not muted and the volume is not on Low.
  7. Click on the “Speaker Settings” button on the “Volume” tab of “Sounds and Audio Devices Properties” and again make sure it is not muted and the volume is not on Low.
  8. Click on the “Audio” tab of the “Sounds and Audio Devices Properties” window and make sure your default audio device is correctly selected.
  9. Click on the “Advanced” button in the “Sound Playback” section of the “Audio” tab of the “Sounds and Audio Devices Properties” window and see if your speaker set up is set to “none”.
  10. See if you have any audio codecs listed. If you it could be a problem.
  11. Try to find another sound card to swap out to rule out the sound card having been zapped.

I hope I got a few suggestions in there that you haven’t tried. Good luck.

Off the top of my head:

  1. Rather than simply reinstalling the drivers, try completely removing them from the system, rebooting, and then reinstalling them.

  2. If that doesn’t work, try and locate a set of older (or newer, if available) drivers for your on-board sound’s chipset. Do as in point 1), but install the older (or newer) drivers.

  3. If that doesn’t work, try re-installing DirectX. It could be that DirectSound has become corrupted.

  4. Try running the system file checker for possible corrupt Windows files. Click Start->Run, and type “sfc /scannow” (without the quotes) to see if there are any problems with critical Windows files. You will need your Windows CD to reinstall any files it deems problematic.

Thanks for the input so far…

I went back and redid everything I could on the posted suggestions—even if I’d done them before, because you never know.

In addition, I just:

[li]set a restore point[/li][li]ran sfc /scannow[/li][list]
[li]it ran, asked for the XP CD, the progress bar reached the end, and it closed without further dialogue[/li][/ul]
[li]reinstalled the sound drivers by:[/li][ul]
[li]uninstalling them through device manager[/li][li]rebooted[/li][li]installing via Windows Found New Hardware Wizard (had to insert the original Motherboard CD ROM)[/li][li]rebooted[/li][li]Uninstalled again[/li][li]rebooted[/li][li]Canceled New Hardware Wizard, and installed directly from the CD[/li][li]rebooted[/li][/ul]
[li]reinstalled Direct X (unpacked directx_dec2005_redist.exe (downloaded from Msoft) and ran the install file)[/li][li]rebooted[/li][/list]

At each stage, I got no sound from the speakers save the clicking when I ran connection sensing via Realtek’s Sound Effect Manager

Something I should have posted above, if it helps. This is from running the DirectX Diagnostic Tool. The warning about WHQL was present before the sound went kaplooey. The Directsound test result is new, and came after I answered “no,” I did not hear a sound playing.

[quote=DirectX Diagnostic Tool]

[li]The file ALCXWDM.SYS is not digitally signed, which means that it has not been tested by Microsoft’s Windows Hardware Quality Labs (WHQL). You may be able to get a WHQL logo’d driver from the hardware manufacturer.[/li][li]DirectSound test results: Failure at step 19 (User verification of software): HRESULT = 0x00000000 (error code)[/ul][/li][/quote]

Lastly, here are the audio codecs I found. Would it be wise to go to the individual directories and manually delete the files? Is there a Windows utility I should use instead? Does anything look fishy?

Again, thanks for the help so far.

I remain quietly yours,


Not to sound overly simplistic, but are you sure you’re plugging the speakers or headphone into the right jack? There are typically three (some have only two, some have more), one for line in, one for mic in and one for line out. On most newer boxes, they’ll be standard color-coded: line out is green, mic in is pink and line in is blue. They might have text labels, or little icons; the headphone/speaker out connection will either be a headphone or a little speaker.

Heh… you can’t be too careful!

I’ve checked, rechecked, double-checked, double rechecked, and Czeched.

I’ve even called Rhythmwife over to check, just to be sure I wasn’t insane. She assured me I was, but confirmed the connection was in the right socket.

I’ve looked at both the motherboard manual and the connection diagram that’s part of the Realtek tools—both say green, both have a diagram of the connections and point it out (just in case I woke up colorblind).

Running connection sensor finds power speakers (or headphones, when I tried with them) in the right connector.

In a fit of desperation a while back, I even tried plugging the speakers into the ‘wrong’ jacks—with no such luck.

Which is why I’m going nuts… everything seems to be in order, but still no sound. Egad!

If everything seems in order, then it could be a hardware problem with your onboard sound. Trying a 2nd sound card would help determine that.

Indeed, I would be thinking at this point that the problem very likely may be hardware, which would require a secondary sound card to confirm.

The WHQL message is largely meaningless. It just means that the developer of the drivers you are using have not submitted those drivers and paid their fee to get Microsoft to put their stamp of approval (“Windows Logo certification”) on them as being fully compliant with Windows XP.

I wonder if the onboard sound is disabled in the BIOS. Have you checked in there to make sure it’s enabled?

Checked a few times. Went so far as to intentionally disable it, save/exit, saw that it took effect (i.e. volume/sound options were grayed out in ctrl panel), rebooted, turned it back on, saw that the volume/sound options were back in effect, and still nothing. I’ve done this more than once.

Remove and reseat the sound card??