Now what's causing THIS toilet issue?

Here’s the scenario:

I flush. All the water comes out of the tank and the toilet flushes as normal. But there’s no water going back into the tank! The intake spout doesn’t have anything coming out of it. The valve to the tank is wide open and it obviously filled up the last time without a problem.

If I close the valve to the tank all the way, then open it up again, water starts to flow.

Doper plumbers (professional and amateur), what’s causing this?

Depends on the type of valve mechanism. In a traditional float valve, it sounds like the float is stuck on something and not dropping to the bottom of the tank.

No, I’m talking about the water supply valve from the house water to the tank, not internal valves.

So, you’re saying that if you shut off the water to the toilet and then turn it back on, the toilet will refill? Assuming it’s a multi-turn valve, the screw on the bottom of the stem probably backed itself off and the washer is moving around freely. Closing and reopening the valve gets it out of the way.
If you’re feeling adventurous, shut off the house water, remove the stem and see what’s going on. But I wouldn’t do it with A)a new valve ready to go in case this one can’t be put back together and B)it’s during Home Depot’s business hours since plumbing projects require multiple trips to the hardware store and you’re not going to be able to turn your house water back on until you get the valve put back together.

But, I would still check the float in the toilet. The pressure drop/increase might be enough to trip a stuck float inside the toilet and my original theory wouldn’t make much sense unless someone’s been using the supply valve recently.

Take the lid off the toilet, flush it, and when it doesn’t refill, make sure the float is dropping with the water. If it isn’t just push it down by hand and it should refill. I would check that before tearing apart the supply valve. (The float will either be a big ball on a metal stem or a collar around the big plastic tube on the left hand side of the tank).

The shutoff valve to the toilet is not going to stop working between flushes. This is an internal toilet valve problem. There are only a couple dozen valve types to work with. Here is a page showing a majority of them.

It sounds like the valve is hanging up which could be a piece of pipe corrosion that has made it’s way into the mechanism or an outright failure. What is likely happening is that the loss of pressure and then applied pressures knocks the tank valve back into function. It’s sticking.

Have you tried pushing the float down by hand? Sometimes they get kind of gunked up and don’t drop.

I’ve seen this happen when large loose solids get in the line water feed. The chunk of mineral was plugging the hole through the shut off valve. Removing the shut off and taking the chunk out of the feed line worked. I just re attached the valve and then the toilet supply line and it worked great.

Water supply - Chunk of mineral: Valve - Toilet supply line

Water supply - : Valve - Toilet supply line

Turning off and on the valve worked because it dislodged the blockage until it shifted again and plugged the valve.

I had someone else on this board check their shut off valve and that was their problem too.

To be clear I’m referring to shut off valve near the wall and not a valve in the toilet.

This happened to me recently. I figured it was something to do with the float valve attached to the inlet pipe, but couldn’t see a blockage/problem. So I just replaced the valve (very cheap) and it worked. Can’t be that hard – I’m a girl who knows nothing about plumbing.

Okay, thanks, folks! I’ll check things out now that I have some idea of what might be happening.

Those shut-off valves rarely fail in the way you suggest. It sounds more like the fill valve to the toilet is sticking. You unstick it when you relieve the pressure at the valve and then open it up again. Buy a new fill valve for $5 at the hardware and go from there. Always go with the obvious and cheapest solution first and this is it. This is normal maintenance for a toilet anyway.

PS. Take the model of your toilet with you and measure the inside height of the tank. A cheap adjustable model will handle from 10"-15" for example. Certain special designs may not be available everywhere. Take a good look in the tank before shopping. Chances are a universal model will work.

After searching around online - nothing helped - then after playing around with the assembly long enough I noticed that the rubber seal on top (under the cap, then 1/8 twist off white plastic peice to see seal under that part) had a small hole after close close inspection - headed to local hardware and found replacement for $2.50 (whole assembly was on sale for $9.99 lol) Regardless saved the $7.50 and bought piece of rubber and it now works perfectly again :slight_smile: GL All

I had this exact problem a few weeks ago. Having absolutely no skill at plumbing, we had a plumber come in. He had to replace some pipe work and coated the pipes not replaced. It was an obstruction, and it ended up causing a leak (which we found before it did significant damage, but it was still annoying). Most of the fixtures and pipes in our home are still the originals, which means over 60 years old. Hopefully the repairs can hold another 60 years (which will be longer than I can hold).

I saw this post yesterday and had to post. Had the exact same problem. Toilet would flush fine but it wouldn’t fill up (or in my case very very slowly). When I turned off the water supply to the toilet and turned it back on, it would work and fill up the tank. Was going to replace the water supply valve. Like others above mentioned, the problem, in the end, was the fill valve (inside the toilet). Replaced it (cost 20 bucks) and it works fine now. And believe me, I’m not handy, it was an easy fix.

Here I sit, broken hearted.
Pooped a zombie
and farted.

I wonder if jayjay ever fixed his toilet. Things could start smelling a bit after a few years…

Heh…I don’t even remember what fixed it at this point! But yes, it was fixed. :smiley:

After 16 years, it would have gone beyond smelling into “seemingly-innocuous compost”.

2011, so five years. Although I HAVE been here since 2000…

Oh my god…I’ve been here since 2000… :eek: