Open file dialog files showing in random order

If this is the wrong forum for tech support questions, then mods please move it.

I have a Dell Inspiron 6000, running Windows XP. All the latest updates are installed.

Whenever I open a file using a program, all the files will display in random order. This started a few weeks ago, when previously they would display properly in alphanumerical order. It’s a pain when I want to upload a certain picture to the internet, they should be ordered by image number as they all came from the same camera, but since they’re not, I have to search through dozens of files to find the one I want. Also a pain when I’m trying to load up the next episode of a TV show, where they are all labelled in the format “showname season xx ep yy.avi” and then I have to sort through 20+ files looking for the next one, where they normally should be in order.

Everything shows up in the proper order when I browse the folder in Windows Explorer.

Anybody have any idea what could cause this? Also how to fix it?

Can you click on the “name” bar at the top to sort alphabetically? They’re probably sorted by date or filesize or something right now due to a misclick.

Ok, so it’s not random, they are sorted by filesize. There’s no “name” bar, but right clicking and going to view brings up an option to sort by name. That fixes it, but it doesn’t stick, and when I open the next file, they are again sorted by filesize. Any thoughts?


If you right click and click view>details, you’ll get a columnar view that can be sorted by clicking the column headings (which is what JSexton is talking about).

It sounds as though you’re seeing it as view>list, which can be sorted by right clicking (as you discovered), and clicking view>Arrange icons by>[several options]

Oh, okay, now I see what he was talking about. It still won’t stick, though. The next time I open a file they’re back to being in random order. Is there any way to make it default to view>details, or view>name, for all programs, all the time? This is what it used to do, so I must have changed something accidentally somewhere.

I can’t remember for certain, but I believe that the standard controls (including the File Open dialog) follow the settings for folders. So, if you go into Windows Explorer and set the default view to Details, it should apply to the dialog you’re having trouble with. Certainly, I always set my default view to Details on a new Windows install, and my File Open dialog is always in that mode when it opens (I haven’t used XP in quite a while though, so YMMV).

Like I said in my original post, the files were showing up properly (ie the way I wanted them to) in Windows Explorer.

I don’t know why I didn’t just go to Google in the first place. I found the solution on this message board. Although it seems that his directions are a bit over complicated. For anyone else who has this problem, the issue can be solved by setting the view how you want it in any open file dialog (in any program), then holding crtl and closing the dialog window.