Outlook question - mail to myself shows in plain text

When I send mail and include myself as a recipient, it shows up in my inbox in plain text format instead of HTML. Everyone else gets the HTML version and it shows in my Sent Messages folder in HTML. Is there a setting somewhere to change this, or just something I should live with?

I’m using Outlook 2007, but it was the same in 2003 before I upgraded.

Do you receive mail from other people in HTML or does everything come in plain?

There’s a feature that may be turned on:

To turn on the Read all standard mail in plain text option in Outlook 2007, follow these steps:

  1. Start Outlook 2007.
  2. On the Tools menu, click Trust Center, and then click E-mail Security.
  3. Under Read as Plain Text, click to select the Read all standard mail in plain text check box.
  4. To include messages that are signed with a digital signature, click to select the Read all digitally signed mail in plain text check box.

When the Read all standard mail in plain text option is turned on, you receive the following notification on the InfoBar at the top of the e-mail message:
This message was converted to plain text.

Email that I receive from others is in HTML. Email that I send is in HTML.

This is the way that I want it. The problem is that when I send an email (HTML) to a bunch of other people, and CC to myself (actually it doesn’t matter if my name is in the To, CC or BCC). Everyone on the list gets the email in HTML format except me. My inbox shows the message in plain text.

If I go to the Sent Items folder, I can see the message in HTML.

I found the problem. Apparently the “auto complete” for my own email address was corrupt in some way or another. When I deleted that and typed in my address again everything was OK.