PhotoShop printing problems

I have PhotoShop CS2, and an Epson Stylus Photo RX595. When printing a photo from PhotoShop, it only prints about the top third of the photo, and a little strip from the bottom, leaving the middle blank. Certain colors also have a weird graininess to them, like they’ve been run through the posterize filter or something (it hasn’t been).

I’ve already reduced the filesize, have tried both RBG and CMYK, tried letting both the printer and PhotoShop determine color management, tried printing the PSD and the JPG, and have messed with the printer settings every which way (photo vs. best photo quality; photo vs. photo RPM; Photo Enhance color management on and off).

The photo looks great on screen, but I need to be able to print a number of copies of this.

Does the printer work correctly with prints from other programs?

Does the picture look okay on the screen when you hit “Print with preview”? I assume it does, just thought I’d ask.

Try opening up a random image file (anything) in CS2 and printing that out. If it prints okay, we can narrow it down to something odd with the file, otherwise we can go from there.

PS I would take whatever picture you use and adjust the image size to be the same as the one you are working with.

Oh, one more thing, are you sure there isn’t something wonky going on with the layers/masks/selections. You might try flattening the image before you print it and hitting deselect all for good measure.

this is a long shot, since I’ve never encountered this problem, but are there any alpha channels or paths interfereing with it? Also, make sure you’re in 8-bit color depth.

Another thing to try is import the image into InDesign or Quark or something, and see what that does.

I just tried printing via Picasa2, and the printer did absolutely nothing at all. I didn’t even get an error message.


The printer just spat out the page without making any attempt to put ink on it. :rolleyes:

Yeah, I resized it and also saved as a JPG so layers/masks/clipping paths aren’t an issue here. I tried it both RGB/8-bit and CMYK/8-bit (the guy who sold me the printer told me that Epson printers work better in the RGB color space, and that seems to be the case as when I tried CMYK the reds got kind of purple-ish).

Random thought – another problem I’ve been having with my computer in general is that the guy who built it only set up 10 gigs of space on the C: partition, apparently assuming that it would only house the OS and 10 would be plenty. Of course this isn’t true, as some software doesn’t let you choose where to install (it’s C: or nothing), plus caches, page files, random other system files that automatically go into C:, so at this point C: has almost no space left. (Yes, I’m planning to re-do this as soon as I can, I need to set up a full image/backup of my computer on my external hard drive first). Could this be part of the issue? I’ve already re-set PhotoShop’s scratch file to go on the other partitions.

I have the same printer and program, and have no problems at all. One thinh I’d try is saving the .jpg to a memory card and and printing right from the card using the printers built in card reader. That should eliminate any CS2 issues and prove that the printer is operating correctly.

When you say the printer “spat out the page”, I think you’re saying it ejected and the print head didn’t travel at all, right?

Have you removed and reinstalled the printer drivers? Operating system? Windows, Mac?

I have no idea how to do that. There isn’t a card slot in my tower. I could save it to a thumb drive but there isn’t a USB slot on the printer.

Also, ultimately, I need it to print from PhotoShop. I’ll be doing a number of edits, including text, and I need to be able to control how it looks on the page. This isn’t a snapshot, it’s a headshot that needs to look professional enough to send to an agent.

Yes… the paper was pulled through but the print head didn’t move.

Haven’t tried messing with the printer drivers beyond running the automatic updater (says my driver is current). It’s been printing Word docs and PDFs just fine for weeks, though. (I’ve had it for about 2 months. On a related note, have you noticed that the nozzle gets gunked easily? I keep getting streaky text, and have had to do a head cleaning twice in the time I’ve owned it, and it’s not exactly under heavy use. It seems excessive, is it just me?)

OS is Windows XP x64 Professional.

Okay, with further experimentation it seems that the disk space issue is at least part of the problem… I dumped the Bridge and Camera Raw caches, which freed up about 450 Meg of space, and now the printer will actually print out the entire image.

However I’m still getting that weird grainy effect, plus obvious horizontal lines from the print head. Any thoughts on those? I’ll be doing the back up and hopefully the partition resizing tomorrow night, so I can further experiment if it’s the lack of space is the entire problem, but if there are other things I should be trying please let me know.

Have you aligned your print head?

In the past, with other Epson Photo Printers, I’ve gotten an 'orange peel" effect. This was when I used non-Epson paper. Apparently some papers are not compatible with Epson’s inks. Since then I’ve made it a point to use Epson’s papers, or accepted the fact that I may get crappy results.

That could be the “grainy” effect you’re getting. Are you using Epson paper?

As for the streaks, a print head alignment is always a good idea as mentioned by pulykamell.

As far as head cleaning cycles, the more you use the printer, the less problems you’ll have because the ink in the nozzle won’t have a chance to dry out.

I aligned the head a couple weeks ago after cleaning the nozzles again. I would hope I don’t have to align them again this soon?

It’s possible. Run through your printer diagnostics and see if the test prints indicate another alignment or nozzle clean is in order. Banding problems indicate some sort of head alignment problem. I’ve had to run multiple passes of nozzle cleans on Epsons before–it’s not an uncommon problem.