Ping vs Traceroute: Response on one, not other

I’ve got a remote server that I supervise.
It failed to report in to the management system, so I tried to connect on the web UI for the server. Port 80 isn’t talking back to me.
I ran tracert, and I got responses from all the hops on the way to her, then responses from her, followed by a dozen “Request timed out.” messages at which point I kill the tracert.

How does it send responses to tracert but not ping?

Ping is ICMP, tracert is UDP.

You may have a port on a router out there blocking ICMP packets, but allowing TCP/UDP. Did any of your network or router configs change recently?

Well, we had a merger recently, so yeah, the Bay gear is coming out and the Cisco gear is coming in.
Ping has worked at all of my previous locations, for what that’s worth.

Not much, depending on how you network is protected and provisioned. I’m going to guess you’ve got a hop in there with a filter on it. Probably have to call for the network engineers.

From wikipedia:

But it also says that when you get a response from a router that your tracert packet has exceeded its TTL (the responses that you did get from the various hops), that packet is sent as ICMP, so it can’t be that something is blocking all the ICMP packets in both directions.

The -I option to traceroute should cause it to use ICMP packets instead of UDP.

I’m a bit suspicious about that explanation. I think that it’s far more likely that whatever machine you’re pinging is configured not to respond to ping.

Rysto, if he was pinging yesterday, and isn’t pinging today it’s likely network. It’s possible the box doesn’t respond to ping, but all of his other boxes do, so that would imply something in the route rather than something on the box.

If the OP is using tracert (Windows) rather than traceroute, then UDP is irrelevant, because tracert only uses ICMP echo requests, like ping does.
As to how the target can respond to tracert but not to ping, well the responses are different. ICMP Echo Reply in the case of ping, ICMP Time Exceeded in the case of tracert. It is possible that the former is blocked while the latter is allowed.

To remote manage a router, I’ll use MSIE to browse to http://x.x.x.x:8080
(where x.x.x.x is the IP address of the router.) I thought 8080 was the typical port for remote management. What is port 80 for?


Port 80 is HTTP.

HTTP can use any port, of course. 80 is just the conventional default. And you can use TCP port 80 for other things, if you really want to confuse people.
Router manufacturers can therefore use any port they like for the HTTP-based remote management. 8080 is common, but a lot of them just use 80.