Please help solve this hard drive mystery. It will not install properly.

My new computer came with a Western Digital 1TB SSD drive installed. Up until yesterday, the drive was working fine. I don’t know what it’s done to piss off my computer, but apparently they are no longer on speaking terms. The computer will not recognize the drive when installed the usual way via SATA cable. The drive isn’t broken though. Nor is there a connection issue. Here’s what I’ve done to troubleshoot:

  1. Pull drive. Replace with a regular HDD connected to the same SATA and power cables. That other HDD works perfectly when connected to the same cables.

  2. Connect the troubled SSD via SATA–>USB device to laptop. The laptop reads the drive and the drive functions properly. All data previously on the drive is still present, readable and writable.

  3. Connect the same set up from #2 into the original host computer. The host computer reads the drive when connected through USB. Read/Write, etc, all functions properly.

  4. Thinking that I’ve ruled out hardware, it must be software. So I move everything off the drive and successfully format it.

  5. Reinstall the newly formatted SSD back into the host computer via proper SATA cable. The computer does not recognize the drive.

  6. I’ve gone to Disk Management to see if it’s just waiting to be allocated a drive letter or something. Nope. It doesn’t read the drive as present in either the Disk Manager or the Device Manager.

I simply don’t get it. The only other thing that looks odd in the Disk Manager is that there is a rouge unallocated 32GB disk, which I just assume is the Optane Memory which is currently waiting to be assigned a drive to enhance.

I don’t get it. Anyone have a clue??

I think something might be screwed up between the Optane and this drive. I may have assigned to the optane to this drive at some point unintentionally thinking it was the mechanical drive, and then unassociated them improperly, or rather, remove the disk without dissociating the optane or something. I thought I had it enhancing the other platter drive, but I may have conflated the two. At anyrate, a reformat should have fixed any issue with that on the drive’s end, right? Is there something I need to do to flash the optane memory or something? Could that even be what is causing this problem?

Did you check the BIOS?

I know vaguely about the BIOS. I remember the 3.1 days of going in there and assigning the boot order of the drives and such. Havent entered a BIOS to poke a round in probably decades. Is the interface generally the same? What should I be lookibg for or doing in there? Also, how do I get there? I think it used to br F12 or F8 during boot up or something?? I will try it when I get home. Let me know what you suggest and I look for or do and I will do that.

I had this issue earlier in the year and found a community that insisted the answer was to connect the drive and have Windows perform a Memory Diagnostic scan (10 minutes-ish). That sounded pretty dumb to me but I was desperate so I tried it and it totally worked. After the test, the drive was available in Disk Management and worked fine ever since.

This probably won’t help but I’ll leave it here because others with my problem may come to this thread.

When attempting to clone an SSD as the new boot drive to a dell computer I fumbled for a few days trying to get it recognized.

I finally stumbled upon a suggestion by somebody to check my boot up settings and look for something like a “hardware lock” setting.

Sure enough I found mine was on. It’s a feature that remembers the physical characteristics of the internal boot drive and will not boot from any other device. I guess its purpose was to prevent data theft via an alternate boot device.

The suggestion was to switch it off, install the new boot drive, then switch it on again.

I switched it off and left it off as the computer was a home recreational computer and required no additional theft deterrents.

No dice. The test did say the results would be displayed after reboot, though. However, nothing happened after reboot. There was nothing displayed and nothing to indicate the test had even run. It definitely ran, though. I checked back periodically to check on the status.

Here is a shot of what I believe is the BIOS screen. It looks different than I remember. It’s been a while. Anyway, the system recognizes that there is a drive installed. It’s listed under SATA3_3, which accurately reflects the SATA port I have it connected to.

Digging through the Advanced Mode, I see that the system listed it as a HDD, though SSD was an option. I changed it to SSD, but it made no difference upon restart.

Still a mystery. I do appreciate all the help.

What immediately hits me is that the Intel SSD that you have at the top of your boot order is not listed bottom left.

I see you have RAID mode enabled. Do you actually have any drives RAIDed? If not, disable it.

Not really familiar with Intel Optane, but it’s a specialized M2 SSD drive, intended only for memory cache. I have a Samsung 256 MB M2 drive as boot drive on this system. M2 mounts on the motherboard. Looking at your boot order in the BIOS, I see “Intel SDDPEK***” listed first, before your SSD. I wonder if it’s attempting to boot off the Optane SSD? You might try moving your SSD ahead of that, and if that works , investigate whether the Intel drive should appear in the list at all.


Quartz got in while I was typing.

Of course, I meant 256 GB, not MB. Damned short edit window.

To be clear, the Intel SSDPEKNW512GB disk listed at the top of the boot priority is an M.2/PCIe NVMe SSD which holds the OS and my primary programs. It probably should also be listed in the M2_1 section of the Storage Configuration. Strange that it is not. Similarly, the Optane Memore should be listed under M2_2, but it’s not. Both, however, are otherwise working fine. Under Boot Priority, the SATA3_1 disk is my 6TB 7200rpm HDD. Under that is the Blue Ray optical drive.

Under Storage Configuaration, SATA3_2 is a HDD (Working fine), SATA3_3 is the problem drive, a 1TB SSD that is not visible to Windows. SATA3_A1 is another HDD (working fine), and SATA3_A2 is the Blue Ray drive.
The unused SATA3_0, SATA3_1 share a lane with M2_1, so I can’t try those ports. Likewise, SATA3_4 and SATA3_5 are disabled due to the active Optane Memory sharing the lane in M2_2. Regardless, Other drives plugged into SATA3_3 work fine, so it isn’t the port, cables, or configuration causing the issue.

I don’t think I have any drives using RAID. I figure I’d know if I did, right? I will disable it and see if that helps.

Download a disk manager and install it on a flash drive. Run it and see what comes up.

That seems to have done the trick. It is visible and working fine. The only strangeness is that it shows twice under Disk Management. It is listed properly and shows its drive letter and volume label and everything. Then, it is also listed as Disk 4 “Offline”. It says that it is offline due to a signature collision with another disk that is online. I’m sure the signature collision is with itself, but I’m not sure how to fix it. I’m much less concerned now though, since it is working at least.