Podcast stopped dowloading

I’m still using an iPod because, when running, it’s a whole lot more comfortable to have this cigarette lighter-sized device clipped to my belt than my significantly-larger phone, attached uncomfortably.
I mostly listen to podcasts while I plod around the track at a local park and I have a blend of humor, opinion, science, etc.
However, about two weeks ago one of the podcasts stopped downloading through iTunes (on a Windows 8 machine, older version iTunes, more on that later.)
All my podcasts are working fine except one. (Savage Lovecast if it matters.) I contacted the tech-savvy, at-risk youth and they say they’ve not changed anything. I haven’t changed anything in my settings, or on the computer either.
The new podcasts (from 1 and 2 weeks ago) show up on the list but don’t download and give the “!” symbol that something’s wrong. If I click on it, it says that there’s an error and I should check the URL of the show. I did that. It’s fine. As a matter of fact, I can manually try to subscribe to the podcast from the URL and the same thing happens. The new podcasts won’t download.

I usually listen and delete. I tried going to the iTunes store and re-downloading an older show that had successfully downloaded before The Trouble and it won’t download now (same error message) either.
I tried subscribing with both an hhtps:// and an http:// lead. Both do the same things.
Before posting here I searched the Apple community forums. I found over 20 people reporting this same instance but with no solution. The most prevalent solution was “update iTunes to the latest.” In that case there was a 50-50 split of people fr whom it worked. I am not on the latest, but I don’t think this is my problem as ALL my other 'casts work fine. Surprisingly, most of the threads asking for help on this problem have no responses there at all, so I came here.

Any thoughts?

I’m going to bump this, once, because I want to believe my fellow Dopers are more informative than the Apple community referred to, above.

Is it possible that your internet connection is filtered in some way, and it’s been flagged as “objectionable” content?

Can you access the main website for their syndication service, www.libsyn.com ?

Can you run a traceroute (instructions here) to savagelove.libsyn.com (and www.libsyn.com) and post the results here?

I’ve had a similar issue with my podcast player. On someone’s advice I unsubscribe do then resubscribed and it worked.

Thank you for the responses, and sorry for the slow response but the new episode drops on Tuesdays so I wanted to see if today’s was any different. Unfortunately, it wasn’t.

First thing I tried (well, after trying various swear words, none of which helped.) It made no difference. On trying to download the new episodes I got the same error message about checking the URL.

My internet connection should not be filtered. As proof I offer that the downloads were working fine until two (now three) weeks ago. And all other podcasts are working properly. Further, I can manually navigate to the podcast URL and download the missing episodes. I just can’t get iTunes to do it. (Which is what I really want as I let iTunes manage episodes listened to, or paused in the middle. Something that I can’t do if I manually download. In that case they’re MP3 files that iTunes thinks are music. So I can listen to them but can’t pause for later, have to manually delete, etc.)
I’m providing the traceroute but isn’t this something that iTunes does behind the curtain?
('ve munged with ### the first steps in the interests of privacy.)
Tracing route to www.libsyn.com [] over a maximum of 30 hops:

1 <1 ms <1 ms <1 ms modem.Home []
2 20 ms 19 ms 19 ms phn4-dsl-gw07.phn4.qwest.net [removed-my ISP]
3 19 ms 20 ms 20 ms 71-32-###.###.phn4.qwest.net [71.32.my ISP]
4 * 20 ms 20 ms
5 * 80 ms 80 ms ae-2-19.bear1.Pittsburgh3.Level3.net []
6 80 ms 80 ms 80 ms GIGLINX-INC.bear1.Pittsburgh3.Level3.net []
7 * * * Request timed out.
8 80 ms 80 ms 80 ms libsyn.com []

Trace complete.
Tracing route to savagelove.libsyn.com [] over a maximum of 30 hops:

1 <1 ms <1 ms <1 ms modem.Home []
2 19 ms 19 ms 20 ms phn4-dsl-gw07.phn4.qwest.net [removed-my ISP]
3 22 ms 20 ms 20 ms 71-32-###-###.phn4.qwest.net [71.32.my ISP]
4 37 ms 35 ms 30 ms los-brdr-02.inet.qwest.net []
5 30 ms 29 ms 30 ms be3201.ccr41.lax05.atlas.cogentco.com []
6 30 ms 29 ms 30 ms be3243.ccr41.lax01.atlas.cogentco.com []
7 42 ms 42 ms 42 ms be2931.ccr31.phx01.atlas.cogentco.com []
8 51 ms 51 ms 52 ms be2929.ccr21.elp01.atlas.cogentco.com []
9 51 ms 51 ms 52 ms be3046.ccr21.den01.atlas.cogentco.com []
10 64 ms 65 ms 64 ms be3035.ccr21.mci01.atlas.cogentco.com []
11 82 ms 83 ms 82 ms be2831.ccr41.ord01.atlas.cogentco.com []
12 92 ms 92 ms 92 ms be2717.ccr21.cle04.atlas.cogentco.com []
13 92 ms 92 ms 92 ms be2821.rcr21.pit02.atlas.cogentco.com []
14 92 ms 92 ms 92 ms
15 * * * Request timed out.
16 * * * Request timed out.
17 91 ms 91 ms 91 ms

Trace complete.