RAID-0 possibly corrupted: am I hosed?

I have a Shuttle AK35GTR with a built-in Highpoint RAID controller. My main hard drive is a pair of 40GB drives striped together for speed (RAID-0). I was about to put in a 120GB drive to back up my data because I know that it’s stupid to have striped drives without a backup. I was doing a reboot to check what my system was like in a pristine state, before I completely powered down to install my backup drive, and here’s what I got.

It POSTed just fine. It flipped through the onboard RAID process just fine. The BIOS report regarding IRQs and so on all checked out. Then it said “Updating ESCD Data… Success!”.

The hard drives clicked once, and the ANSI graphics from the BIOS checkout jumped one line upwards. All of the lights on my USB keyboard came on and stayed on. The computer stopped doing anything at all.

I’ve tried altering the BIOS settings, but it feels to me like the RAID controller has “forgotten” that the drives are there and striped together. I’m a little bit scared to go mucking about with any of the low-level settings in this case, because if the RAID’s integrity is busted, I’m going to have a hell of a time getting the data off of it.

So, Dopers, how bad is it? Should I start crying yet, or hold off? Will installing the new drive, formatting it to NTFS, and having the spare space on-hand be a useful precaution, or is it more likely to cause harm than good?

I know relatively little about raid, but as a general test of your MB’s hardware integrity why don’t you try flashing the latest MB BIOS update to it, and see if it takes before re-connecting the drives.

I can’t say for sure regarding Highpoint controllers, but most of the higher end RAID controllers I’ve worked with let you create a RAID container without initializing the drives. In other words, recreate your RAID 0 without loss of data.

I’ve had to do this several times when a RAID controller craps out and needs to be replaced. I would be surprised if your controller doesn’t offer this option as well.

Next time buy a 3rd drive and use raid 0+1 or raid 5. I seriously doubt you were getting much of the speed benefit of RAID 0 over an IDE channel.

Sometimes just re-seating all the cables fixes problems.

If you can get the PC to start at all with the RAID drives connected, there are utilities that might be able to recover your files. While waiting for this thread to load, I followed a link from another one, and stumbled across this, just for example. (The demo only does small files; the full version is $40.)

I’d get the new drive in and working first so you have a place to put any recovered files.

Whether drives are IDE, SATA, or SCSI has no bearing on the performance benefits of RAID0. Each drive is communicating to the controller at its maximum speed (probably around 40MB/sec in this case). The controller provides to the system the illusion of a single drive with 80MB/sec of throghput. IDE transfer rate wouldn’t enter into the equation unless the drives were faster than the transfer rate selected, which is impossible with today’s technology. With large arrays, however, it IS possible to hit the limit of the PCI bus (133MB/sec). And just to note, most IDE/SATA RAID controllers are only two-channel, requiring that a seperate RAID controller as well as more drives be purchased to make RAID5 possible.

My RAID controller only supports two modes: RAID0 and RAID1. I set it up as RAID1 almost two years ago before I realized what the downside was. My current problem occurred just as I was attempting to set up some redundancy. At this point, your advice regarding “next time” is not much consolation – I’m still holding out a little hope for making it through “this time.” :frowning:

Sorry, but these RAID controllers are really software RAID. Read the performance reviews if you don’t beleive me. The performance gains are not anything to write home about, and while there may be a speed increase, all you are really doing is doubling your chances of data loss byt having to drives instead of one.

Have you been into the RAID BIOS to see what it says?

Yes. Ordinarily it lists each of the two 40GB drives as “STRIPE FOR RAID 0” but right now it’s just referring to them by their model numbers. I figure I’m boned.

OK, you’ve got a backup, haven’t you? Or at least no data that you mind losing? Then you can try and recreate the RAID but don’t initialise it. You should be ok.

The difference between a RAID controller implemented fully in hardware, such as a 3Ware controller, and a normal low-end RAID controller that uses the CPU for processing is minimal with RAID0 and RAID1. Naturally the hardware controller will have somewhat lower CPU usage and slightly higher throughput, but differences only become significant when using RAID5, which requires a large number of mathematically complex ECC operations. In the case of RAID0 with two drives, you WILL approximately double your HDD throughput even on a software controller. I achieved an 85% improvement in sustained read performance (from 47MB/sec to 85MB/sec) by RAID0ing two Western Digital Special Edition 250GB SATA drives on a Silicon Image Sil3112A software RAID controller. Such results are typical, and Silicon Image isn’t even one of the better controller manufacturers.

Interesting article

Software RAID vs. Hardware RAID

To be fair, that test was done by Adaptec, which manufactures expensive hardware RAID controllers thus has a vested interest in showing significant performance differences. The test was clearly designed to maximize the performance difference between the hardware controller and software RAID array. Also, that test was doing RAID fully in software, as opposed to a “software RAID controller” which is a RAID controller that offloads some calculation work to the CPU, like a winmodem.

No joy there. The Highpoint RAID software/firmware gives you that warm & fuzzy dire warning when you try to re-create a RAID: “ALL DATA WILL BE LOST!” Or do you mean go ahead and do this, pray that it doesn’t overwrite anything more than the boot sector, and then try to fudge together a new boot sector to regain access to my old data?

As for having a backup: remember back in the OP, I said that I was shutting down my machine to place a 120GB drive inside the case. That drive was to become my backup. The thing that makes me want to put my fist through my monitor is that after years of narrow escapes and close calls with losing my data, I finally decided to back up my data with something more than crossed fingers.

I can’t isolate a reason that this could happen other than pungent irony. I have operated this RAID trouble-free for almost two years. And the very moment I decide to back up my data it craps out.

That’s terrible. I’m suprised that Highpoint doesn’t allow you a non-destructive re-create option. What would happen if your motherboard died and you needed to replace it?

On researching this a little, I came across a person who accidently deleted their Highpoint RAID container and was unable to recreate the RAID without deleting the data. This person contacted Hightpoint directly who sent him a file called “hptrm3”, which allowed him to recreate the RAID.

Maybe worth a try?

Wow, that’s the best lead I’ve had yet. Did you find that with Google? I thought I had been pretty aggressive about digging for this sort of thing.

I’ll give it a try and report back. Thanks!

If you google “hptrm3” you’ll see where I got the info from.

Wow! In the same tech support thread that mentioned the vendor-supplied solution, I came across a mention of this third-party product that claims to be able to repair (and recover data from) a RAID-0 that has fallen apart. I’m going to wait to execute a plan until I hear back from Highpoint’s tech support team, but the testimonials for this DiskScavenger software are glowing. One of them specifically mentions a problem almost exactly like mine, with a completely successful outcome.

Unless the Highpoint guys present me with a better solution, I think I’m going with the third-party software. As ever, I welcome constructive debate on my course of action. I’ve been burned by impetuous moves before, so I’m taking it slowly this time. Anonymous Coward, I’m particularly pleased with the advice you’ve given so far. I expected you to be an expert, because I’m familiar with your posts on Slashdot, too. So many informative posts – and such a sense of humor! :smiley:

But seriously: mad props for finding me that thread.