Safari Won't Open WikipediaFor the last week or so, Safari can't open wikipedia anymore. I don't ha

For the last week or so, Safari can’t open wikipedia anymore. I don’t have trouble with any other websites. I can open it in Chrome, but I use Safari more. All I get is a screen that says “can’t open website” or something similar. I already tried clearing the cache, and that didn’t do anything.

Safari Version 6.0.3 (8536.28.10)

I tried seeing if I needed an update, but all I seem to get from the Apple site is the ability to add on “extensions”. It’s unclear to me if I am missing some key extension and if I am, which one.

Any advice

You are wickedly out of date, dude. Safari Version 8.0.7 (10600.7.12) is the current iteration.

Yeah, I’m slow to update. But I can’t even figure out how to update. I go to the apple site, and all I get are “extensions”.

I’d say just download the latest one; you can get it at : https://support.apple.com/downloads/safari

Wait; what OS are you using?

I’m just going to go ahead and do an overall update.

But still, what’s going on with wikipedia that’s so special? It’s the only website I encounter that I can’t open.

If it’s the only page, you might have accidentally misspelled “wikipedia.org” and the resulting typo doesn’t have a domain. Even if you have it bookmarked, you still might have accidentally changed it and just not noticed you did so.

No, that’s not it.

Anyway, I upgraded the whole operating system. And, of course, there are new “features” that I absolutely hate. Worst of all is that my clock now runs 4 minutes fast. WTF, Apple??? But, I can now load wikipedia!!

Just set the clock to set itself in the Date & Time control panel.

OK, did that. Thanks. I don’t understand why the upgrade didn’t just carry over my previous preferences, and then I’m wondering if the clock doesn’t set itself, and I never entered anything, where did it get the [incorrect] time from in the first place?

Funny how any opened application now has a little black dot to the left of it whereas previously it would have had a little white dot to the right of it. The white dot was a lot easier to see than the black dot. Just seems like a silly thing to change…

The real time clocks in computers are very inaccurate. That’s why the option to self-set from an accurate timebase is there. You old system was probably not set up update the time, and it just slowly drifted…

As for the “running app” indicators, they’ve changed over the years as transparency has gone in and out of style. The is some control over their appearance in the Control Panel.

One other question. A new “feature” is that when I put the cursor in the address bar, there’s a drop-down menu that automatically pops up with a whole bunch of icons from different web sites I’ve visited. I find this really annoying since many of these are sites I haven’t visited in years. I’m not sure where it gets these from, but I’d sure like to disable this “feature” completely.