Slowwwww computer

There’s this computer at work, with a 1.6 GB hard drive, 32MB RAM, a 133MHz processor, which is hooked up to the network. For some reason, this computer takes FOREVER to close a file. It can open and save no problem, but it’ll take 5 minutes to close anything.

Any ideas? I’ve scandisk, defrag, clearing the hard drive… And all the other computers are the same and work perfectly fine.

Could be a lot of stuff… but I’d look at the video card first (can you update the drivers?), or maybe adding more RAM (actually adding more RAM is almost a MUST if you’re running Win 9x!)…

Good luck!

This computer is only running Excel and Access. It doesn’t NEED RAM or a video card.

Defrag the Hard Drive. Do a ctrl-alt-del and see what else is running. If anything is unnecessary, stop them by running MSCONFIG and disable the startup items you don’t need.

I disagree with your RAM statement though, I don’t know of any wintel system that wouldn’t benifit from having 64MB of RAM. (I am taking for granted you are running win98 or 95 here).


Your post mentions that other computers with the exact same configuration in the office work perfectly fine, yet this one continues to be significantly slow.

My guess would be network/network card related. I would suggest two tests.

  1. Move this workstation to a different network connection, Do not move the cable with the computer.

  2. If the computer is still slow, swap network cards with another computer that works fine.

If neither of these is indicative, then I would strongly recommend having the machine checked for hardware problems like a faulty memory chip, causing less than the 32 meg of ram present to be usable.

Are there any other symptoms?


I would also try completely removing and reinstalling Office.


Sorry, I didn’t (ahem) notice what you already did to try to remedy the problem.

A computer taking that long to close down sounds like disk-thrashing. In other words, it’s having trouble saving system files and clearing memory to hard disk. A hard disk that’s more than 70% full is essentially full – this is the most-likely cause. Defragging can help, but an overly-full hard disk is like a file cabinet that’s stuffed too full with paper – you can’t find things even when efficiently stored.

A second possible cause is that system files are damaged. You could run RegClean and check your autoexec.bat and config.sys files but that has a level of risk and requires some knowledge of what you’re doing. Best alternate suggestion: reinstall the OS.

A few questions/points:
1: Mooney252’s point is where to start first. The drive is relatively tiny at 1.6 gigs and unless you have at least 300-400 megs free, excel and access will want to scroll to the disk continuously to create virtual RAM with a 32 meg system. The “closing” vs opening or saving operation involves getting the data out of both real and virtual disk ram and making a final, non-incremental write to the disk.
Which leads to item 2:

2: Re the RAM issue 32 megs is pretty light for excel and access unless you are running older versions with tiny spreadsheets or databases. The MS 97 and 2000 versions of these programs are notorious memory hogs. A machine with the specs you mentioned will be a bit of a sluggish doorstop relative to the needs of excel and access in MS 2000.

3: If you save a file locally to the C drive, does it take as long as saving it over the network to a remote drive.
If there is a substantive difference you most likely have a network config issue to deal with.

4: Having said all this (and assuming you are running 95 or 98) I might also suspect that you have a configuration error in how your system is set up to deal with memory under the “system” settings in the control panel. Look at the other machines that are not bogging and see what their RAM/disk space/network settings are. If your slow machines settings are OK check under the performance/file system settings under the “system” icon of control panel of your machine vs the other machines.

Yes, Win 98. The other computers at work also have 32MB RAM, except the server which has 128MB, I believe. they’re a little sluggish, but work fine. Remember, it’s not opening or saving the files that are the problem. It’s closing the files. Also, while a file is closing, I can actually go and open Excel/Access while the other one is closing, and it’ll work almost as well as usual.

Things I have already tried:

Defrag, clearing the hard drive (it’s only half full now), checking which other programs are currently running (not many), moving the computer to different work station, running programs like Rambooster, reinstalling Windows, reinstalling Office.

I’ll try saving a file to the local drive and see how it works. Getting some new hardware is basically my last resort. I figure I’ll just replace the whole computer instead of getting it fixed.

Have you tried increasing the disk cache/swap file? (In W98 it is called virtual memory) Having too small of a swap file size could cause serious slow downs of the kind you described. The figure I have heard is that the swap file should be 2-2.5 times the size of the RAM.

First thing I would try is to save a file to a floppy instead of the HD & see how long that takes.

Mooney252 is on the mark. Formatting the HD and doing a clean install of the OS is the easiest fix for the problem you describe. Install only the minimum software required to get the computer to do what you want it to do. Set a fixed swap file size; 3x the size of physical RAM is usually fine. Install the latest drivers for all hardware in the system. 64MB of RAM in such an old system may not be cost-effective. SDRAM prices are dropping but EDO SIMM prices are not dropping so fast.

I just tried having the file on the hard drive. Same effect. Opens and saves fine, closes slowly. See, if it did EVERYTHING slowly, I wouldn’t be asking here. Why would it only CLOSE a file slowly?

a search engine is a handy thing:
"Sluggish closing of files is probably the single
most common complaint from Microsoft Word
users who upgrade to Office 97. The slowdown
comes from a feature that many
users–perhaps most–don’t even realize

             Microsoft Outlook offers a feature called the Journal,
             which can track several kinds of events on your
             system. By default, one of the things it keeps track of
             is everything you work on in Word. Whenever you work
             on a document, the Journal records the filename, the time you created or opened
             it, and the length of time you've worked on it. You can view the details as Journal
             entries in Outlook 97 by choosing Go | Journal or by clicking on the Journal icon
             in the Outlook bar to go to the Journal.

             The Journal records these entries whether Outlook is loaded or not, and very
             likely it records them even if you've never bothered to open Outlook at all. Alas, if
             you aren't interested in using the Journal, the time it takes to write the entries to
             disk is simply unwanted overhead.

For reasons that aren’t at all clear, the overhead can be virtually unnoticeable on
some systems but annoyingly time-consuming on others. Whatever the
difference is, it isn’t simply a matter of CPU speed and RAM. My test-bed, for
example is a 90-MHz Pentium with 48MB of RAM. That’s severely underpowered
compared with the Pentium MMX/233 with 64MB of RAM mentioned in the letter,
but closing Word on my test-bed with a file open takes only a second or
two–even with the overhead of a Journal entry–compared with the times of over a
minute mentioned in the letter.

             Fortunately, if the overhead is bothersome on your system, there's an easy way
             to turn the feature off. Open Outlook and choose Tools | Options, then Journal.
             You'll see a number of check boxes for items to track, including one for Microsoft
             Word. Remove the checks from all of the check boxes and the sluggishness of
             closing programs should disappear."

thats all I could find at this point but you can search some more.