So why doesn't dirtyfound.com work for me?

So, a friend of mine directed me to dirtyfound.com, after she told me that she found a rather charmingly dirty Polaroid in a local creek while doing fieldwork, and posted it to the site. When I go to the site, though, I see the headings and the comments, but none of the found items. Can anybody explain? Is this because I use AdBlocker?

PS: disabling AdBlocker does nossing!

It appears to be a porn search engine which gets it’s links from the users. I’m not exactly sure how your friend could have “posted it to the site.”

But, no, I have adblock, and none of the images were blocked. Heck, it doesn’t even take you to the images, but to the site they are found. Perhaps the site you found is just bad.

I believe you mean http: //www.dirtyfoundmagazine.com/ (I don’t notice anything NSFW but I broke it just in case)

Only one of the pictures is showing up for me. Most of them don’t work.

Hmmm… looking closer it also seems that site has not been updated in over a year. Not sure if it’s the right one or not, if it is I wouldn’t expect your friend’s picture to be posted anytime soon.

I’ve never been able to get it to work for me, although I can’t remember how long ago I first tried/how long since I last tried.

Sorry. Forgot about this thread.

Sheesh. “Submitted”, then. Is that better?

Should have noticed that myself. :o Thanks!