Split Hard drive

A friend of mine was getting the “disk full” message all the time and so I told her I’d look at her computer since she shouldn’t be getting that message unless she had an incredibly small hard drive. (this is a Dell laptop running Windows 98, btw). I opened My Computer, and sure enough C: was only 2GB, but then I noticed a D: and E: that also had the “hard drive” icon. Her CD-ROM was F: I had a hard time believing that a little laptop like that actually had 3 separate hard drives, so I opened the device manager. It listed only one hard drive, but under the settings, “DMA” was checked and C, D, and E were reserved.

My questions are, Who did this? (not my friend, I’m sure), why was it done? and Is there a safe, quick way of making this machine think it only has one drive again, so she doesn’t have to decide which letter to save stuff under each time?


I’d venture to guess that the reason it was done this way was the system was originally installed with FAT (which dates back to DOS 1.1). This is a 16-bit filesystem that supports a maximum of 2GB per drive. Is it possible the laptop originally had Windows 95 on it? That OS does not support FAT32[sup]1[/sup] (the current version of FAT, which supports filesystems up to 8GB). To get around that problem (which is apparently what the installer did), you can use fdisk.exe to create several partitions, each 2GB.

To fix the problem, first ensure that the filesystem on the C: drive is FAT32. I’m guessing here, because I’m not on a Windows 98 system (I’m on Win2K), but if you bring up My Computer, then right click on the drive in question and choose Properties, it should tell you what filesystem is on the drive. If it’s FAT32, you can proceed with the next paragraph. If it’s FAT, you’ll need to convert to FAT32 first, which you should be able to do with Start->Programs->Accessories->System Tools->Drive Convertor. You may need to free up some space on the C drive before you can proceed.

You should ensure that there is no software installed on the D or E drives, because once you combine the drives you’ll have a hell of a time getting it working again. Yes, it can be done, but it’s probably easier to just reinstall the software. Having done that, the next thing you should do is BACK UP THE SYSTEM. I will not be held responsible if something goes wrong, and that’s always possible when you play around with this type of stuff. After that, go to download.com and get Partition Resizer. Then run fdisk.exe and delete the D and E partitions (this is assuming that you’ve determined that there’s nothing on them; if there is, you’re on your own). Then follow the instructions in Partition Resizer to expand the C drive onto the space freed up by deleting the other partitions.

After you’ve done that and rebooted, your CD-ROM drive letter will have changed to D:. You’ll probably want to tell Windows 98 about that; you can do it with regedit:
1.Start Regedit
2.Go to HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion \ Setup \ SourcePath
3.Change the value to D:.

Hope this helps.

[sup]1 Yes, I know that Win95B supports FAT32, but I didn’t see any reason in complicating the issue[/sup]

It occurred to me that it’s unlikely that a laptop that originally came with Windows 95 would be have a large hard drive, so my reasoning may have been faulty. Having said that, you can still follow the same procedure (although first check the size of each drive to see if it’s worth following).

Well, take it from me, it’s better not to change drive letter around. You can make a real mess of things real quick. However, W98 docs should tell you how to do this safely: (if this isn’t it, youll find w98 has more info undter the start menu then ‘H’)

To change the drive letter assignment for a disk or CD-ROM drive

to open the System Properties dialog box.
Click the Device Manager tab.
Click the plus sign next to the type of drive, and then double-click the disk or CD-ROM drive for which you want to change the letter.
Click the Settings tab.
Under Reserved drive letters, change the drive letter assignment.
You can also open the System Properties dialog box by clicking Start, pointing to Settings, clicking Control Panel, and then double-clicking System.
If the option to change the drive letter assignment is unavailable, you cannot change the drive letter.

Thanks, Frog
This machine was purchased last summer, so i’m going to assume that Win98 was installed on it to begin with. So I don’t have a clue how this came about. Not only that, but it came with MSOffice installed on D and there was nothing on E. I moved Napster and MP3s over to E to free up space on C, so I am just going to leave it like it is. I might give Dell a call and see what they have to say about it.


The infamous “disk full” message reminded me of a similar situation with a friend of mine. Since I had built the system for her (a P100 desktop, 2.1 GB hard drive, this was some years ago…), I agreed to take a look. This gal was a long ways from being a power user, and her modest collection of mostly WP files was no strain on that li’l HDD… BUT, she had a scanner AND an incredibly self-enamored 16-year-old daughter.

To make a long story short, the kid had scanned in a single color photo (of herself, naturally) at some INCREDIBLY high resolution, and that single file was just over 1.5 GB. There was another scan – same subject, of course – that was around 260 MB. Thus, in a single sitting, I encountered not one, but two record-breaking files, at least in terms of size, in my experience.

I did a little looking around my class (we have mandatory laptops and several got these Dell Latitudes) and many of them are split the same way. Does anyone know if this is something Dell does regularly?

" Does anyone know if this is something Dell
does regularly?"

Probably. I seem to remember it on my friends laptop too. It Might be a way for the system to function?

I have a two-year old Latitude with the same thing- 2GB hard drive split (C: is 1.5 GB, D: is .5GB), but was and still is Win95.

Doesn’t make much sense.

      • Hard-Drive related: when you defragment a hard drive in Win98 (possibly other Wins), there’s a button marked “show details”, that displays each sector as a little rectangle and colors it as to its status. Some of them are marked white with a red square in the upper corner and are classified as “data that is not to be moved”. What is this data that cannot be moved? -I noticed that the very first sector of the drive is “not to be moved”. What’s in the first disk sector?
      • Also, I had a 6 gig HD. I bought a 20 gig HD, and after giving up on transferring everything directly, I removed the 6, installed the 20 and used a system recovery disk to reformat and rebuild the 20. I later put the 6 back as a slave drive. So far, everything works 100%, but I noticed that I never did enter the 20’s parameters (cyls,heads,sectors) into the BIOS, yet the Windows system info on it says 20.something gigs. Did the Win98 CD find all that out on its own? When would one need to set the disk parameters in the BIOS? - MC