Suddenly no sound on computer

I’m terribly sorry to ask a computer question, but I’m at my wits’ end. I’ve got a really stupid error.

WinAmp was playing. Pricegal turned the volume (in WinAmp, not via Volume Control) down to zero to answer the phone. When she turned it back up, the sound didn’t come back.

In Volume Control, all controls are enabled and set to the highest. When sound is playing, I see the coloured indicator growing and shrinking, showing that there is in fact sound playing.

I have a Sound Blaster Live! Value sound card. I have uninstalled it and reinstalled, rebooting in between. No difference.

I have run both Norton Antivirus and AdAware.

I’m running Windows 98 Second Edition.

The problem isn’t isolated to WinAmp; I can’t get any sound in any application.

Any ideas?

Forgot one thing: I have, of course, checked the cables from the sound card to the subwoofer and from the subwoofer to the speakers, and made sure that the volume on the speakers is turned way up. And that the speakers are turned on.

Since you’ve been so thorough, I’d imagine you’ve also unplugged the speakers from the sound card and plugged them into a radio, or other source, to make sure the problem is not with the speakers.

You are talking about the audio controls in the Control Panel, right? Is there a check in the Mute All box? If so, get rid of that. Mine does that by itself from time to time. Very annoying.

I haven’t, for one reason: I wouldn’t have a single clue what I was doing. Sound technology is a big black spot for me; I know precisely nothing. The only reason I’m sure the speakers are plugged in correctly now is that a) the sound was working fine before the volume in WinAmp was turned down and no-one has touched the speaker cables, and b) the cables and contacts are colour coded, making it possible to do it right even for a clueless guy like me.

If you can tell me what cables to plug into a radio, I’ll try it. Two cables run from the sound card to the subwoofer. Four cables run from the subwoofer, two to the front speakers and two to the back speakers. Can I just take any one speaker and plug it into a radio or CD player, or should I plug the ones currently in the sound card into the external device?

Ethilrist, the sound isn’t muted in Volume Control.

In a previous lifetime I was tech support guru for a sound card mfgr. So here’s my triage procedure for missing sound:

[li]Is your computer plugged in? Is it turned on (don’t laugh, it happens!)[/li][li]Do you have a sound card (not so much an issue these days.)[/li][li]Do you have speakers plugged into your sound card? (old-time computers didn’t output sound card sound through the built-in speaker; some new ones do)[/li][li]Check to see that your speakers are plugged into the sound card, into the correct socket. Yes sir, I KNOW you checked that, please check it again. Thank you. (Don’t get burned on this one, you’d be surprised how many times the customer swore it was plugged in…)[/li][li]Plug a set of headphones into the speakers and test the sound. If that works, check your speakers with some electronic device.[/li][li]OK, no sound from card period. Open your volume controls, turn everything up, ensure that mute is not set anywhere, check the advanced options.[/li][li]Still no sound. OK, let’s figure which sounds don’t play. First put an audio CD into your CD-ROM drive and play it (CD sound comes from the CD player and only routes throug the sound card’s mixer).[/li][li]OK, you have CD sound but no wave/MIDI sound. It’s either a driver problem or a card problem. For XP, not likely a driver problem unless you’ve installed some weird software lately.[/li][li]OK, you have no sound still. Hmmm. Most likely a bad sound card if the mixer isn’t working, but may also be driver. Only way to be sure is to test the card on another computer. If the sound chip is built-in (very likely on most modern off-the-shelf systems), 90% its the hardware.[/li][/ol]

Check the speakers before doing anything else. Then check the mixer (volume control); mixers are always getting reset. Figure out which type of sound ain’t working (CD, wave/MP3/etc., MIDI). Back when I was a boy (and programmed by candlelight), the problem was mostly that the computer was too underpowered to do sound, or the OS was screwed up. Any computer from the last 10 years has enough power, and any Windows OS (after WIN 3.1) is usually robust. That leaves dead hardware or weird interactions.

Sorry I can’t help Mac or Linux/UNIX users.

So long as the connectors are the proper type, you should be able to plug each speaker into your stereo to test it individually. I also used to have a setup in which my computer surround speakers were plugged in (via the subwoofer) to the amp attached to the DVD player.

Check the speakers first, to make sure that it’s not those.

I did once have this problem with Winamp, but it only affected Winamp and was solved by reinstalling Winamp. It never affected sound from other programs though.

Another thing that you may want to check is in Winamp under Options, Preferences, Plugins, Output is not set to Disk Writer, although that wouldn’t affect sound in other programs, so it’s unlikely that it’s the cause.

It’s working now, but I certainly don’t know why. I pulled the subwoofer out of its hiding place to unplug the speakers and plug them into a CD player, when I saw that the speaker connectors weren’t of the “long thin silver thingie” variety (does this technical talk make you as hot as me?) and so couldn’t be plugged into my CD player. I was in the process of taking pictures of the connectors to show you guys when I noticed a tiny white button marked “DIAGNOSTIC. PUSH.”. I pushed it, and each speaker in turn emitted a high tone. Then, each speaker emitted a loud, deep bass. It rose in volume and I pushed the white button again to stop the diagnostic. The bass stopped, being replaced by the euphonious voice of Britney Spears, who was being played on WinAmp at the time.

If anyone has an idea of why this happened, let me know.

Glitch? Something in the onboard firmware locked up?

No idea, really. I know this is GQ and I should be posting some kind of wonderful factual answer, but it now seems like a firmware glitch.

Was this mentioned or did I miss it?

Check the volume control in the Task Bar, remove check mark in box.