TI-89 Hates Me (oh god help)

I just got this thing, upgraded from an 83+. Oh man. I can’t make it work. In the little ;_______________ box, if I type something like “45*59” it goes “ERROR: Syntax (ESC=CANCEL)”. It’s in decimal. Radians. Please help me figure out how to get it to stop thinking I’m syntaxically wrong.

Yeah, TI-8x’s suck. Get a real calculator, like an HP. :slight_smile: :slight_smile:

Gee, aren’t you helpful.

I’m sorry, what do you mean the little ;___________ box? Are you in the program editor or something? If you’re not in the HOME field, try doing some calculations there and see if that works.

If you just “got this thing”, you still have time to go back to the store and exchange it for an HP. :slight_smile:

Skeptico, I’ve used TIs for my whole history of using graphing calculators. I just made a big step and wasn’t sure what was going on. Switching to an HP was not recommended by my college professor anyway for the work we were doing, since she uses TIs also.

Achernar, I have no idea what the ;_____ box was. Basically, the little bottom thing where you enter data, but it had a semicolon on the leftmost side. I guess it was a program editor; I turned on the calculator and poof, it was there. Maybe I accidentally pressed a button combo after putting in the batteries. But I pressed HOME button and now it works! Thank you very much. Now if I have problems I can at least get ones referred to in the manual. :smiley:

Well, in the program editor, every line starts with a colon. The same with the text editor. But the program editor shouldn’t be giving you any errors until you run it. I just flipped through my manual and I couldn’t find any prompt or command line that has a semicolon. It could be the partial differential equation editor for all I know. :slight_smile:

In general, if you’re going to use it like a calculator, you’ll be wanting to stick with the Home field (or whatever it’s called). It’s easy to get to by pressing HOME, as I’m sure you figured out. Good luck!

I’ve sed TI calcs for a good chunk of my life. I have no idea what is wrong, but here is a few things which might help.

  1. Turn the calculator off and on again (hit button [2nd] then [on], then hit [on] again).

This (at least on my quite similar TI-92) puts you on the home screen. You could also hit the home key, which is [GreenDimond][q] on the 92.

  1. hit [clear] and then select “clear home” from the F1 menu.

What you should see at this point is a set of menu options along the top of the screen, a black space in the middle, and the aformentioned box thing at the bottom (which should be empty, and flashing a verticle line for a cursor).

type in your multiplication, and hit enter. (just to be precise, the key strokes would be [4][5][5][9][Enter]. If all goes well, the command line will read 45*59, and be hilighted, and the same will appear on the left side of the screen, near the bottom. Opposite it will be the answer, 2655 in this case.

If you still get a syntax error, hit [esc]. Does the cursor move to some point other than the end of the expression you just entered? For instance, is it flashing between the * and the second 5?

In general, a syntax error will move the cursor directly after the first symbol in the expression you entered which the calculator does not understand.

If your calculator does something different, and/or if the cursor moves, it may be helpful to make a note of it.

Most of what you said is the same in the 89, but the HOME button is its own button. Also, if you press [GreenDiamond][on], the calculator will turn off, but when you start up again, it will be wherever you were, not necessarily the Home screen. I thought about mentioning this, because it could be why Toaster never saw the Home screen, but I forgot.

RPN is the ** DEVIL !!! ** :mad: :mad:

if you get really confused, you can always remove the batteries, and the backup battery, and that will reset you to home 4 sure.

however, of course you will lose all your data / programs ( but you don’t have any yet right ? )

by the way i love this calculator. i could never figure out how to use 83, but 89 is quite intuitive because of its windows-like menus.

hell, i can’t even figure out how to use regular scientific calculators with the memory button :slight_smile: nothing can be easier than a TI 89 :slight_smile: don’t exhange it for HP.

i have a graph link for it too, only that piece of shit dont work with windows XP. it used to work when i had win 98.