Truly odd computer problem (re: graphics speed)

Ok… about a week ago, I had a 1 ghz Athlon, 640 mb of memory, an ATI Radeon 7500 and some random motherboard (I don’t recall exactly what kind).

Running Rainbow Six: Raven Shield, I regularly got FPS scores that were somewhere in the mid 30’s.

I got myself a late Xmas present, and got an BFG tech Asylum GeForce FX 5200 AGP card.

With no other modifications beyond installing the latest and greatest Nvidia drivers, I jumped up to somewhere around the upper 30s.

I had trouble with my system, so I swapped to my buddy’s old motherboard, with 1 GB of memory on board. FPS jumped up to mid-40s.

So after narrowing the problem down to the motherboard, I bought and installed a super-cool Gigabyte GA-7N400 Pro2 motherboard and another 512 MB DDR SIMM.

I wiped my boot partition and reinstalled Windows XP from scratch, set up the system about the same as I had it before as far as tweaks and such go. I also installed the latest Nvidia Nforce motherboard drivers and Geforce Fx 5200 drivers.

For whatever reason now, when I run Raven Shield, my FPS sits down around 15 FPS. This totally baffles me, as I’ve done everything I can think of to improve that.

I must be missing something obvious… anyone have any ideas or suggestions?

Well there’s a few things I can think of that might help.

First, in your BIOS you need to make sure it has the CPU clock speed and memory speed set correctly. When I built my computer last year with an Athlon XP 2700+ the BIOS selected the slowest clock speed it supported by default and I had to change the settings to the actual clock speed of my processor. When I built my cousin a computer last week (with an nforce 2 motherboard, I believe) it set the memory bus speed to the slowest setting by default, resulting in low memory speed and a CPU speed lower than that of the actual processor.

Second, I looked up the motherboard you purchased and the site says it comes with onboard GeForce 4 MX video. You need to make sure the onbaord video is disabled in the BIOS and that you have not connected the monitor to the onbaord video connector. Also, in the BIOS, change the default display device to your AGP video card and not the onbaord video.

Third, you did not say what OS you were running before, but if it were something other than Windows XP then resolution may be your problem. Windows XP defaults to 800x600. Earlier versions of Windows let you run in 640x480. So if you were running a different version of windows before the resolution may be set higher now, causing lower frame rates. (Though with your setup I would think it should still be running faster than 15 fps.)

Fourth, you may want to check your bit depth. If you were running 16-bit color before and now it is set to 32-bit color then this could be your problem. The higher the color setting the more work your video card has to do to draw the screen.

Fifth, you should check on your refresh rate. If you were running 60HZ on your old setup and now you are running, say, 85HZ then the increased refresh rate could cause video slowdown.

If none of this works then there may be some other, more obscure problems you are having, so come back and let us know what happens.

Note: All video settings (res, color depth, etc.) should be checked both in Win XP and in the game settings. Most games let you setup your video independent of the OS, but if it doesn’t (which isnt likely) it may be borrowing your video settings from Windows.

install your motherboard AGP drivers. You ar not getting your full bandwidth if you re only using windows generic support.
Your motherboard should have come with a driver disk to support any on board sound, Lan, or vid functions. The disk should also contain AGP drivers.

I’m betting a driver issue is to blame for the reduced performance. In this case, since the card isn’t really an upgrade over what you had, I’d suggest trying to return the card for a refund if at all possible, and pick up a more modern ATI videocard, such as a Radeon 9600. This should work around the driver issue, as well as providing improved performance.

Sorry i didnt see that you said you DID install the motherboard drivers.
One thing that you might look at is what your anti-aliasing settings are in the nvidia toolbox.
Also the check box “texture sharpening” has been known to cause trouble for some systems.

Found it! I had to dig pretty deep on message boards to find that CTRL-F1 unlocks a bunch of settings on Gigabyte boards- like AGP aperture size. Increased that to 128 mb, and I was off to the races! 90-130 FPS now.

Thanks guys!