Trying to share files on two windows 7 PC on a wireless network. Help.

I simply want to be able to transfer files between the two. Both are running W7 (one is Ultimate, the other is Home Premium)

I created a Homegroup on one, but the other can’t see it (says there’s no homegroup)
Any help?

ETA: I’m able to share by entering the IP address. I think that will do me for now (but it would still be useful to know how to create a working homegroup)

Use the wizard to setup sharing:

Control Panel\Network and Internet\HomeGroup

If you share often, you can even map the network drives so it shows up in Windows Explorer for each machine.

Here’s the easiest solution: http://dropbox.com.

Dropbox designates a folder (Usually My Documents\My Dropbox on PCs or $HOME/Dropbox on Linux and Macs) as a dropbox. Anything placed in that dropbox gets copied to a server, and you can go to a webpage and take files off the server.

However, the real fun is simply subscribing to your dropbox on various computers. Each computer you use Dropbox on will share that dropbox. I can copy files from work to home and back again by simply placing the files I want in my dropbox folder.

You can also share folders with other Dropbox users. For example, I have shared folders for everyone in my family. If I need to give someone a document, I simply put it in their shared folder, and they get it on their PC.

Dropbox also versions files, so if I make changes, I can get back the older versions of a file. If I delete a file, I can undelete it. Dropbox has a free service that gives you a 2Gb dropbox. Larger dropboxes are available for paid subscriptions.

Dropbox is the easiest way to share files between computers and works with PCs, Macs, and Linux machines.

Sharing for Windows has changed between XP, Vista, and Windows 7, and it’s a big friggin’ mess. I have Macs and a Windows 7 machine, but sharing files between a Mac and PC is very difficult. I usually have to know the IP address of the machine to get it to work. The PC makes no attempt to share with my Mac, but I can setup my Mac to share with my PC.

You probably have to setup a Shared folder. I am not 100% sure how that new Home Group thing works, but I am very disappointed with Windows 7. For example, in XP I could change the permissions in such a way that I could limit certain users to certain programs. Windows 7 Home Edition doesn’t allow me to do this.

I spent hours attempting to setup my computer power saving features. Things that were easy to setup on Windows XP are hidden on Windows 7, and I have no idea why. I can understand keeping things simple, but power users will find a lot of frustration in setting things up.

As I said, get Dropbox and use that.

The Point of my OP is that it’s not working as expected. I created the homegroup on one, so in theory on the other one I should simply ‘join’ it. But it’s only giving me the option to create one. So I’ll end up with two networks each containing one PC, neither of which is joined to the other.

I said in an earlier post I might be able to make do with just using the ip address, but I have now discovered that while I can access the folders I can’t give permission for one PC to write to the other.

While I was typing I remember the ‘everyone’ permission, so I’ll try that, but I’d prefer to know how to get the damn homegroup thing working.

I am loving 7 but this is the first time it has shown its microsoft colors by doing something non-standard and stupid. Why not just have normal networking?

I got the homegroup bit working by giving one of the computers a different name (it had the exact same name as the other, because of the way windows determines the name - it is my name, then a dash, then the type of machine (PC) so both of them ended up with identical names.

But it is proving to be difficult to give one machine permissions to write to the folder of the other. Even the ‘everyone’ permission doesn’t work.

This reeks of not having been tested. A quality of far too many microsoft apps.

We have one Windows 7 machine which we mainly use for our TV. The problem is I find certain aspects of Windows 7 rather frustrating because I, as a power user, isn’t allowed to control certain things.

For the first time, Control Panels are hidden. For example, look at Power Management. You can set your Power Management Profile, but the option to do detailed settings is now hidden. When you find it, you get what looks like the ol’ Windows control panel.

My machine isn’t going to sleep. I’ve tried setting a command line option, but I’m told I don’t have permission (even though I am the administrator). Okay, I’ll set the policy to allow admins to set it. Nope. Windows Home Premium doesn’t have the Security Policy panel. Grr…

I’m having problems getting this computer to talk to my Macs. I can run Samba on the Macs, but sometimes the Windows machine picks them up and sometimes not. I’ve tried the other way with Bonjour, but the same issue. Grrrr…

I’ve tried setting up SFTP and SCP, but I can’t seem to set Windows Firewall to allow the needed ports. Grrr…

I’ve used Windows NT, Windows 2000, and Windows XP, but I have never run into a situation where Windows simply hides its configurations, so you can’t access them.

That’s why I use Dropbox. It’s just easier to use than trying to get Windows 7 to do what you want.

You need to start a command window with elevated permissions. Right click, Run as Administrator.

I am the fricking Adminstrator! When I open a command window, I’m not running it as administrator?

Crap! You’re right! Another friggin’ hidden Windows option. I originally pinned the Command prompt to the task bar, so I have easy access to it. However, I can’t change the properties of stuff on the taskbar, so there’s no way for me to get this to run as administrator.

I have to first create a shortcut to the cmd.exe file. Then go into the properties, change it to allow the shortcut to run as administrator, then pin that to the command bar. Except for the stupid “Are you sure you want to run this dangerous program” prompt I get, it works.

This is the type of stuff I hate about Windows 7. Almost a decade of Windows power user experience is completely worthless. I’d like to set the Windows system policy not to beep and ask me if I’m sure whenever I open this shortcut. However, I can either have Windows pester me, or turn off the whole security apparatus. There appears to be no way to fine tune this.

Shift, Right Click, Properties, Advanced, select Run as Administrator.

Windows 7 UAC settings:

http://www.neowin.net/news/main/09/01/07/windows-7-whats-up-with-the-uac

Other Windows 7 hidden stuff:

http://blogs.msdn.com/tims/archive/2009/01/12/the-bumper-list-of-windows-7-secrets.aspx

Its probably because the wireless network is not set to Home Network. Easy way is to have the same workgroup name and user/password on each computer. eg: user1/password1 on both computers. then share a folder. I always share to the user not everyone.

What would be the benefit of this over something like Skydrive or Live Mesh? (Aside from the ABM factor, of course.)

(Disclosure: I work at a large software company based in Redmond, and I haven’t actually needed to use any of these three products; so this is a genuine question, not shilling.)

Isn’t Homegroup IPv6 only?

Both my computers have v4 addresses (192.168.0.250 and 192.168.0.240)

There’s also the issue in Vista - is your network set as “public” or “private”? The result is counterintuitive. “Public” means you’re sitting at Starbucks on the public network wifi, and you don’t want someone to see your files. “Private” means you’re at home or office and everyone on the network should see what you share.

Right, A day has passed. I turned my PC on and I happen to click on one of the links somewhere about the homegroup.

This time it tells me the laptop has created a homegroup and would I like to join it.

Then a few minutes later I learn about the ‘Share With’ option (which basically adds a user called ‘Home Users’ to the permissions.
So in the end, it’s working, but my small laptop is ‘running’ the network and the large powerful desktop is a member.

I’d like to have it the other way round, but for now it’s fine like this)