Two network cards mapping two drives on a computer... huh?

I can’t get it to work.

We have two domains here at work. One is the main company network that we all connect to for email, internet, filesharing, etc. The other is a completely independent network that just sits there and has some files.

To access our company network, say, domain COMPANY, the computer is already configured for that. Network properties, the domain controller already has room for the computer and the user, and voila, everything is fine.

To access this other network, say domain INDIE, we have set up a wireless router. Thus, people with wireless cards can in principle access COMPANY with hard lines and INDIE with the wireless. But of course that doesn’t really work because you can only be on one domain at a time. No problem, though, because I don’t care to have people log in to INDIE like they would log into COMPANY, I just need them to share a folder on it for transferring data.

So I set up this little batch script that people could click on in order to connect to the drive if their wireless was up and running. All it does is

net use L: \blah blah blah <etc etc> [not persistent]

in order to set up the L drive as the mapped network drive and the network drive is on INDIE. Usernames are the same. Passwords are the same.

Sometimes L: will connect, sometimes it won’t. Once it connects, sometimes it stays, sometimes it doesn’t.

There is something I am missing here and my non-network-guy-ness is hindering progress here. We do have a guy that comes in once a month for this stuff but I like to know some of it because otherwise any time we have a networking issue we have to wait a month for it… yuck!

Any help here dopers?

You are using NT.

I’m sorry I forgot to mention that, all the computers that would connect to it are Win2K and the server is 2K Server.

Not a real answer but a suggestion. When the techs had to configure a wireless Cisco router and wireless NIC setup (accessing same domain) at work, the NIC card configuration was a real bear as there are multiple layers of somewhat hidden security and access permission protocols (way beyond a home setup) required that reside deep in various setup menus for a wireless Cisco NIC on NT.

I’ve also found that wireless networks are a lot less effective in punching through the walls at work vs at home and that the signal tends to peter out fairly quickly from the source.

Last but not least flakey wireless routers do exist (I had to replace one a month ago). Try getting a cheap wired router and direct wire connection from the server to a work PC and se if you have the same issues. That may indicate whether it’ a server hardware, router hardware, OS or wireless router setup issue.

OK, let me restate that. COMPANY is NT Server and INDIE is 2K server. Everything dealing with COMPANY is fine but the INDIE connection will not work constantly.

Does it have something to do with trying to access multiple domains? Does it have something to do with trying to use two different network cards? Am I reduced to making people log off of one domain and onto another?

I’m going to go with the “wireless signal being flaky” bunch. The next logical step to attempt to isolate the problem would be to log off from the NT server totally and check connectivity to the 2K server over time, and see if that helps.

If you don’t feel like doing that, one thing you could do is open a CMD window and run a continuous ping to the server. Watch it every so often, and look for breaks in connectivity. If you see “Request timed out” intermittently (especially when you can’t map your drive) then it’s going to most likely be the wireless connection itself. (Of course, this assumes that you have ICMP enabled to the server. If not, then this won’t work either.)

If your connection fails and the pings look ok, you can try manually entering the “net use” syntax and observing the error. Hopefully it will return something useful (although it frequently fails silently, unfortunately).

The signal strength never even approaches 50%, it is always passed the 80% mark of full strength. I mean the router is like 3 meters away, definitely not the signal strength.

I’ll check the error out and post again…

I wouldn’t rely on signal strength alone, which is why I recommended running a ping. If there’s interference on the line (or other hypothetical hardware problem), causing a lot of re-transmits and such, it could account for this problem and not necessarily show up as a loss of signal. In fact, if I were there and had a Sniffer on me, that’s the first thing I’d look for. Since we can’t do that, the least we can do is verify the simplist of connections: ICMP ping. It at least rules something out.

I can ping the router and the server (that is, wireless router and INDIE), yes, definitely.

I just did it now and here’s what happens. I will describe exactly what I did.

[[Both networks remained on the entire time.]]

I shut the computer down, restarted, and logged in as myself to COMPANY on the computer. No problem. (I also have assigned myself as part of the administrator group, if anyone was wondering or if that matters.) I run the NET USE command with my name mapping the L: drive. Works like a charm. I can even transfer files from L: to K: (that is, one network to the other). Great!

No internet is available, however. I think I can deal with that.

Also, mapped drives on COMPANY disappear from time to time and you see a little red X on them in WindowsExplorer. We can get errors here (no code, just the message box) that says it failed to reconnect to the drive. L: (the INDIE-mapped drive) is still alive and kicking. I open CMD and try the K: drive… no problem.
I reopen windows explorer and no problem getting onto K: or L: … :confused:[sup]2[/sup] But ok, so then it occurs to me—could there be an issue with both routers using DHCP and I run IPCONFIG and see that, no, there isn’t per se as each network adapter has it’s little IP address correctly corresponding to the various networks (their IP ranges are significantly different).

So there’s no problem there. Maybe the internet can be corrected later, that isn’t the biggest concern (obviously).

I log myself off (I don’t shut down or restart, just a log off) and log the computer owner in. K: drive works as it is supposed to. I can ping the wireless router, and I can ping computers on the other side of it (specifically the INDIE server). But it won’t find the path specified to get to INDIE, which is strange as I just had it working a moment ago.

I hope this makes sense and includes information necessary.