Urgent Mac OS Help Needed!

I have an iBook Dual USB running OS 10.3. Yesterday, it started making a funny noise while I was checking my email and it seemed very hot, so I shut it down. After letting it sit for a while, I tried to start it back up and it only got to the start up page with the apple and the spinning thing.

Next, I tried booting with Norton Utilities and TechTool Pro. Both started up normally (in OS9) but my hard drive did not appear on the desk top. When I tried show missing disks with Disk Doctor it crashed the system.

After that, I tried booting it as a FireWire Target drive on my Wife’s computer. Everything showed up normally, so I tried running TechTool from there. It found some sort of volume error, which I had it repair. It then spent more than 2 hours checking files, so I decided to let it go overnight and check it in the morning. When I woke up, my wife’s iBook had shut itself off. I tried redoing the target drive, and I got a message that I had inserted a disk with no files OSX could read.

Oh yeah, and a little background. I’ve had problems with my laptop before, and while it was covered by AppleCare, it got a new hard drive about a year ago. Any help or advice would be greatly appreciated.


St. Urho

Also, yesterday, I tried rebooting it once and it made it past the apple screen but then went into Darwin and asked me to enter my username and password. It then said I entered the wrong password and went to the desktop. My desktop picture appeared but nothing else. Today it just boots to the apple screen and sticks there.

Have you tried booting from your OS X install disk? From there—assuming it sees your drive—try running (I think it’s called) Disk Utility located in the Installer or File pull down menu. Run Disk Repair and Repair Permissions.*

If that doesn’t work, try reinstalling OS X. There is the option to keep your home folder and preferences, so you should lose anything.

  • I don’t have my install disks handy, so the specific name might not be correct, but it should be clear what is what.

Hmm. I tried that and it failed. There was an invalid key length and “The underlying task reported failure on exit (-9972)” Anyone know what that means? Thanks for the idea, too.

Norton Utilities and Techtool Pro are useless, IMO. If you can afford the splurge, go get a copy of DiskWarrior instead. IME, if DiskWarrior can’t fix it,it can’t be fixed at all.

First things first, though – if you haven’t already, boot up the iBook in Firewire Target mode with your wife’s computer, and save your stuff.

And, of course, if you’ve got Applecare/warranty coverage and a nearby Apple Store or third-party Apple retailer, I’d recommend a visit. It’s cheaper than buying DiskWarrior, and will help in finding any long-term problems you may have.