WD(My Book 650Gb) External USB Drive access Problem

Hi, I got myself a problem with a WD(My Book 650Gb)6400 AAV External USB Drive, I am using WinXP and Linux Mint 9, I bought it a while ago 2th. hand and formated it with Linux using FAT32 as file system.
I used the drive for about 6 months only on Linux. I then got a virus infection on the XP partition, could not fix it and lost access to both partitions and had to format my PC’s 500Mb internal drive, after reinstalling both OS I can not access my WD USB Drive anymore, XP reports file system: RAW
and Linux: online and healthy, “dmesg” reports:

[ 1834.964874] FAT: bogus number of reserved sectors
[ 1834.964880] VFS: Can’t find a valid FAT filesystem on dev sdc1.

both suggest Formating in order to access it.

I know that there is nothing wrong with the drive because it was disconnected when this all happened,
so the question is how do I get my data back? Anybody can help?

Have you tried connecting this to another PC?

Yes I have tried that already with a PC with the same OS’s Linux/XP but the same message comes up, that would mean that there “is” something wrong with the WD drive, so is there a way to look and access the data on that drive? I will also try again with yet another PC with XP only on it, by the way I also tried with the Boot DVD from Linux…

what does it say if you do this:

blkid /dev/sdc1

There are cetain apps like Spinrite that may poossibly allow you to recover the partitions, but on the while it sounds like the partitions are trashed and you need to re-format.