Weird (computer) mouse problem

OK, I can’t figure out what is causing this, Dell’s support site doesn’t have any answers for me, and I’m frustrated, so I thought I would come here and see if you guys can help.

For the last month or so, I’ve been noticing that every once in awhile, the mouse speed slows down for no apparent reason. In other words, I’ll be surfing along normally, when for no apparent reason the mouse pointer speed suddenly becomes slow and sluggish. The only thing I’ve found that fixes it is rebooting the computer. After a reboot, the mouse speed is back to normal. (I have a PC, if that matters.)

The really bizarre thing happened today. Earlier, I was surfing around, and suddenly the mouse slowdown happened again. I didn’t feel like rebooting, so I just put up with it. Several hours later, the mouse pointer (and everything else on the computer) suddenly froze. I couldn’t move the pointer or switch windows or do anything. The freeze lasted for about ten seconds, and when everything unfroze, the mouse pointer speed was back to normal! What the hell?!?

It almost seemed to me like some huge program had been running that sucked up a lot of processor time, and then the program shut down (thus causing the freeze and the subsequent mouse speed-up), but I wasn’t running any huge programs. I was running Eudora, IE, WordPad, and whatever random programs this computer always runs in the background – nothing unusual, from what I could see in the Ctrl-Alt-Delete dialog box.

Does anyone have ANY idea what might be causing this? It’s really frustrating and annoying.

Have you cleaned the rollers?

Oops, should have posted that info too. It’s an optical mouse, so cleaning the trackball isn’t the problem.

I’ve been having the same trouble. Started about 2 weeks ago. It seems to happen most often when playing online games, and occasionally when using IE with “active scripting” enabled. I haven’t noticed it at any other time.
I’m using an Intellimouse Explorer w/ W98.
ZoneAlarm’s log doesn’t show anything unusual.

Unplugging the mouse and then plugging it back in usually fixes it, but occasionally I have to re-boot.

This is just a guess, but it sounds like your system is accessing the cache and getting hung up on it.

First and foremost, what are you using?

When’s the last time you defragged?

What’s you’re cache setting at?

That’s just for starters.

That should also say, “The system is in some kind of a loop. It’s looking for something and can’t find it. That, or it’s overwhelmed with some task that you’ve given it.”

I also wanted to comment on how cool my post looks. Nice and symetrical. Just the way I like it.

I planned that, you know.

My own WAG. It could be a memory leak in one of your programs holding system resources hostage. My 1st thought would be to update the mouse drivers from whoever built it (MS, Logitech, etc.).

Is the optical mouse original equipment or did you recently add it. If it’s a recent add, did the system work fine before?

I agree with pcubed, it sounds exactly like a memory leak.

The optical mouse did not come with the machine; I added it myself shortly after we got this computer. However, I’ve been using it for several months, and this problem only started in the last couple months. But I will try updating the drivers and see if that does any good.

As to CnoteChris’s questions: It’s a Microsoft IntelliMouse and I’m using WinMe. (By the way, IE has never been so buggy as when I use it on WinMe. I mean, really buggy. But that has little or nothing to do with this topic, so I digress.)

I defrag the computer about once every two months. The most recent time was about three weeks ago.

How would I check the cache setting? Is that really going to do me any good? (What is it?)

Which version of IE are you using? Also, to track down programs with memory leaks, use Resource meter, which you can find in Start->Programs->Accesories->System Tools.

To check cache settings, first go to Programs->Settings->Control Panel->System->Performance->File system->Hard drive. Be sure that the computer is being used as a network server. Restart, then go to the same steps, but this time Performance->Virtual Memory. Clean the cache first by disabling virtual memory. Restart, then defrag the drive. Restart again, then re-enable virtual memory, then restart again, and defrag the drive again.