Why can't I network our newest PC? What am I missing?

Why can’t I network our newest PC?

I think I did to it everything I did for our others, but this one can’t see many network resources.

I gave it a static IP address (my whole nework uses static), subnet mask, two DNS servers, a unique name, and the name of our network. I am logged in to the new PC with a username and password that already have rights for the fileserver, and besides, no network resources are asking me for username and password.

Here are some network things that work: The new PC can see the network. It can access the internet over the network. It can ping one other computer on the network.

Here are some network things that don’t work: The new PC can’t see any PCs or folders on the network. It cannot ping most of my other PCs, and cannot ping itself! My other computers cannot ping it (except that the only computer the new PC can ping is a fileserver with no console so I can’t try the other direction).

I tried running the Network Setup Wizard to no avail. I ran the Network Troubleshooting Wizard, which reports that the new computer’s name is already in use elsewhere on my network, but even after trying other silly names for the new PC I get this same report. I tried its other suggestions to no avail.

This new PC is a Dell 2400 desktop model with Win XP Home.

My network is a Windows Peer to Peer network over hardwired ethernet, including a switch, a fileserver, and a router whos WAN side goes to a satellite “modem”.

Can anybody think of anything I’ve missed? Or suggest something else to try? Thanks!!!

This same thing just happened to us when we set up our new Dell laptop on our network. Turns out the Norton Internet Security 2005 program that shipped with the laptop was causing the problem. We disabled it and all of a sudden the laptop could see all the network places. We promptly uninstalled the program and have not had any problems since.

As already mentioned, try disabling (temporarily) any firewalls. If you don’t have a server, and i assume you don’t, make sure you have the following checked on:

START>control panel>Network and internet connections>Network connections> Local area connections (double click the icon)>properties>Internet Protocol (double click or select and click properties)>Advanced>WINS tab>Enable NETBIOS over TCP/IP
this will allow you to resolve computer names to IP addresses without a DNS server. Try it.

Cannot ping itself - that’s the part that gets me.

Let’s say the IP address you assigned is You are saying it can’t ping, right? Have you tried pinging “localhost” and “”, both of which should resolve to the local machine? Can it ping the default gateway.

Don’t worry about file and print sharing stuff for now - try to get the IP connectivity working first. Once that’s up, we can figure out file sharing.

Are you sure the network card is OK? It’s unusual, but there are bad ones. Can you try a different network card? Is the green (or amber) light illuminated on the back of the network card? It doesn’t sound like a hardware issue since you are able to ping at least one server.

I second the opinion about turning off all firewalls while you’re troubleshooting. Don’t forget the built-in Windows firewall, accessible under Control Panel. Let us know the results of these experiments.

Thanks, everybody.

>Enable NETBIOS over TCP/IP
Ahah! Neither Enable nor Disable were selected, rather the reference to DHCP was selected (but I’m not using DHCP). So I selected Enable. But this did not make anything appear in the Network Neighborhood.

For all these experiments the Windows firewall has been turned off.

With Norton Internet Security enabled, the new computer cannot ping its own IP address, but it can ping localhost and With Norton Internet Security disabled, it can ping all the above including its own IP address. It can always ping the default gateway. It can also ping most of the PCs on our net (this morning, anyway - most didn’t work yesterday though some did), including the fileserver, but can’t ping my desktop computer downstairs (which can’t ping it but can ping the others).

With NIS turned off, and trying different things, we have seen my desktop computer downstairs appear in the Network Neighborhood, and also have seen the new computer itself appear there, though at different times (right now there is nothing there and I don’t understand what I did that made things appear). We have not seen the fileserver appear there, whose folders I wanted to map to local drive letters in the first place.

I can’t look at the lights on the rear of the PC because they’re hidden and I have a bad back. But bear in mind that the NIC hardware is doing many things, including internet access.

Did you ever get this one solved? I have to admit, it has aroused my curiosity.

Regarding the non-appearance of computers in ‘network neighborhood’: there are several issues that can cause this; Google for “computer network neighborhood” for some likely solutions. e.g. this one looks interesting: http://www.windowsnetworking.com/articles_tutorials/nethood.html

Another thing to try: enable auditing on the file server, for failed file accesses. Attempt to access the file share from the new machine, then check the audit log on the file server. See if anything appears. (To make sure you’ve set up auditing correctly, deny yourself access to a file on the file server, then try to access it while logged on the file server. An item should show up in the audit log, under Event Viewer.)

This is still not solved and I’m hungry for advice.

>Attempt to access the file share from the new machine
How do I do that? I may be less network sophisticated than you assume. I would try to do this by making some folder on my old desktop machine a shared resource, then on the new machine I’d open Network Neighborhood, select the old desktop machine, and select that folder on it. But I can’t do that because I don’t see the old desktop machine there, let alone the folder. Did I misunderstand what I’m supposed to do?

Network Neighborhood is not the most reliable way to check a network in Windows. It seems that sometimes computers don’t show up even when everything is configured correctly.

Try this instead. Do a search for the computer directly. Go to the Search function in the Start menu. Click to search for “Files and Folders”. When the search window appears, click on “Computers or people” under “What do you want to search for?” Then click on “A Computer on you network” under “What are you looking for?” and type the IP address of the computer to want to find.

Your setup will probably differ from mine, so it may not look the same, but you should be able to find the function to search for a computer.

Do all your PC’s have IPX protocol installed? I had a similar problem on a network my PC was on, as did a few others on the network, and it turned out that those of us who had similar problems you are describing didn’t have the IPX protocol enabled.

You shouldn’t need IPX, NetBeui or any other protocols than TCP/IP. All Windows networking can be done over TCP/IP nowadays, and usually is.

With this experiment, I was trying to see if there are some silent “logon failure” type errors, mascarading as connectivity issues. Let me clarify: suppose your file server is “scooby” and your new machine is “shaggy”. Enable file access auditing on scooby, for “failure”. Then go to scooby and try to access any file you’ve shared. For example, you could try the administrative share. From shaggy, click Start | Run then type


If it prompts you for a logon, that’s a good sign.

Oops. That should of course have been “shaggy”. :smack:

This shouldn’t be all that hard to resolve . . . scratch that, this is Microsoft we’re talking about.

But I think the easiest thing to do, since you have an all-static-IP network (and I’m assuming your DNS servers are external), would be to create an LMHOSTS file and import it into your network setup.

Basically, an LMHOSTS file is simply a list of IP addresses and their corresponding names. You should find a sample LMHOSTS.sam file in your C:\Windows\System32\Drivers\Etc folder; use notepad to modify it.

All the lines that begin with ‘#’ are comment lines. Read them to learn the basics, if you’d like. You could also erase them.

Scroll down to the bottom and type in an IP address, <tab>, then the computer name. Like this: PieceOfCrapNewDell OldPieceOfCrap EvenOlderPieceOfCrap ShouldBeABoatAnchorAlready Mac

The second column needs to match the computer name for each computer. I think it’s case-sensitive.

Once you’ve entered your entire network, save the file. (Heck, save it to a floppy, you can put it on every computer on the network.)

Then go to Start/Settings/Network Connections, right click “Local Area Connection” and select Properties. In the lower box, highlight ‘Internet Protocol (TCP/IP)’ and select Properties. Click the Advanced button and select the WINS tab. Check the box that says “Enable LMHOSTS lookup” and click the ‘IMPORT LMHOSTS’ button next to it. Browse to the file and click OK.

There’s a lot more you can do with LMHOSTS files; check out this Microsoft Support article for things like:

–mapping names to domain controllers (which it sounds like you don’t have)

–specifying which entries should be preloaded, vs. normal entries which are tried when normal name resolution fails. Basically, by putting the switch #PRE after a given computer’s name, that IP-address-to-name resolution would be entered into a computer’s registry, instead of loading after the network starts. This is useful for domain controllers, whose addresses the computer needs to know ASAP after boot-up, but by changing the registry you have to edit the registry if your network later changes.
But I digress. To boil this subject down to its essentials, create the file, save it, import it, enjoy your network.

Just a question, you sure you didn’t give it the same IP as another computer in your network?