Why can't I send email at mcDonalds?

No trouble connecting and receiving but I can’t send.

I’ve had the same problem running Outlook Express as well as whatever program my ancient Ipod Touch uses.

Here’s the error I get…

The message could not be sent because the server rejected the sender’s e-mail address. The sender’s e-mail address xxxxxxxx’, Server: ‘smtp.comcast.net’, Protocol: SMTP, Server Response: ‘550 5.1.0 Authentication required’, Port: 25, Secure(SSL): No, Server Error: 550, Error Number: 0x800CCC78

You need to set up your email software to use your Comcast username and password for sending outgoing messages. Currently, you are probably connecting to their email server anonymously.

Comcast (and many other organizations) require this in order to send email using their servers when not connected to their network, in order to prevent any random shithead from using their outgoing mail servers to spam people.

I’ve bolded the relevant part.

An observation: Most of what the ‘computer experts’ everyone bugs to fix their machines do is paying attention to error messages and getting the most out of them. Simply reading, as opposed to doing anything else, will put you pretty far into the ranks of people who no longer need to waste time waiting for others to figure things out.

Would it have been better to simply ask "How can I fix an Authentication Required error message? I checked a box that might have worked but never wnet back to McDonalds.

Now I’m getting this error on a relative’s home network…

The connection to the server has failed. Account: ‘Chuck Paris - work’, Server: ‘smtp.comcast.net’, Protocol: SMTP, Port: 25, Secure(SSL): No, Socket Error: 10013, Error Number: 0x800CCC0E

Note that in the meantime I sucessfully sent emails at the network of a condo we rented for a week.

Sometimes an ISP will restrict access to their SMTP server to their own IP ranges. If that happens, the result is that you can connect to ‘smtp.comcast.net’ from Comcast ranges but not from outside Comcast’s network.

Other times, an ISP will allow authenitcated access only, either across the board or just from outside their IP range, or force an SSL connection from outside, or something like that.

My advice would be to go through your ISP’s help line and find out (a) if you can connect to their SMTP server from outside, and (b) what settings are necessary to do so?

This is an extremely common problem. To reduce spam, most ISPs only allow email to be sent from their servers if the sender is in the same domain (e.g. - Cox only allows email to be sent from cox.net). When you are at Micky D’s, you are sending from mcdonalds.com, or some such. Some (not all) ISPs allow authenticated logins, which will allow you to send email from anywhere. Check on your ISP’s website, and see if they have instructions for turning on authentication.

You mentioned in the OP that you’re using Outlook Express. Sometimes you can send via the ISP’s email web client, but not a standalone program like Outlook Express or Outlook.

I can send from the Comcast web client (at least I think that is what my account thru their web site is called). I’ve never had any problem doing that.

I’ve had the same problem at every McDonalds. I’ve only had the same problem at a handful of private networks …once I was instructed to solve it by changing the outgoing port from 25 to 1.

Outlook Express has a checkbox “This server requires secure authentication” … I didn’t get a chance to try it at McD’s but I had it checked when I succesfully used the condo units network and when I failed at my brother-inb-laws.

ISPs also sometimes prevent people from connecting to external mail servers on port 25 at all.

One method used by spammers has been to infect people’s PCs with a backdoor trojan, then connect to that PC and use it as a short-term mail server to send out a few million pieces of spam. To fight this, many ISPs simply lock down their network so that end users simply can’t make an outbound connection on port 25 to anything other than the ISP’s own mail servers. This might be what’s happening from your relative’s place.

Essentially, Comcast is saying “We need to be sure who you are before we allow you to send mail from our server,” on the one hand, and your relative’s ISP may well be saying "We’re not going to let you talk to Comcast’s mail server at all.

Yet a third possibility is that McDonald’s is doing a transparent server redirect to their own mail server–you may think you’re talking to smtp.comcast.net but you’re really not. This doesn’t sound real likely based on what you’re reported thus far, but it is possible (usually done so that public hotspot locations can filter outgoing spam and such without blocking common mail clients)


How to set up Comcast using Outlook Express.
Note that it shows screen shots and shows outgoing port 587, not port 25.

587 didn’t work …got a dif error message saying that the server rejected my email address…

Bricker…thanks for your detailed explanation above. I think that my further explanation countered your suggestions but if I didn’t understand correctly LMK.

I’ll just add - when you’re doing this, your email is actually being sent from a mail server in the Comcast network, so the mail server doesn’t know or care that you’re actually sitting in a Mcdonalds, outside the Comcast network.

Good luck sorting this out. I do think that authentication might be the key - when you click the box for secure authentication, did you specify what credentials (username and password) to send to the mail server? Was it just a ‘same as when collecting incoming email’ option?

My nephew fixed the problem, on his home network anyway…

He changed the port to 587 and he properly set up secure authentication. Outlook Express has two differrent checkboxes on two different tabs for that in the properties area of my email account. I had only seen the one box and figured that I had done it. I still don’t understand the dif between the two.

Not sure whether that would have fixed the McDonalds issue…I’ll have to try it some time.