Why would VPN stop working after switching a wireless router?

And how would I fix that?

Could be that the new router doesn’t allow VPN through by default. Go into the router admin and turn all “VPN Passthrough” settings to enabled.

What sort of VPN software are you using?
Who runs the VPN server?
What sort of router did you have, and what is your new one?

Your old router may have had a port-forwarding setting for the VPN connection, or VPN passthrough (as noted above). Or your new router may need to have UPNP enabled. Or your VPN server has MAC address filtering which needs updating to the new routers MAC address.


Critical information.

There’s loads of little fiddly things to get right for VPN to work.

Things get tricky when a VPN device is behind a NAT firewall. There are settings for this but you need to turn them on.

There are several variants of VPN with many settings each.

IP broadcasts do not work over a VPN tunnel.

Fragmented packets need special handling if you want them to make it through.

In your case, one thing I would be looking at is the network settings of the new router versus the old router.

If your local network overlaps the VPN network namespace then trouble ensues (i.e. your local network is and the VPN network is also Guess how I figured this one out. So, if your old router had been modified to avoid a specific range, the new one might be using a factory default range that overlaps the VPN range.

Again, without details it’s hard to come up with better answers.