Why's My Laptop Acting Like I'm Clicking?

Good news: I just got my laptop back from the shop. It’s good as new.

Bad news: The laptop keeps acting like I clicked somewhere, when I didn’t. This is annoying when I’m typing (say in a text box on SDMB), and suddenly the text stops appearing because my cursor is outside my text box,or if it’s in the text box, the text starts showing up wherever the cursor is. I’m just using the touchpad on the laptop, not a mouse. I wouldn’t even know how to google this problem…Any idea on how to fix?

I had that problem, and it drove me NUTZ!

I suspected that the built-in touch pad was developing a static charge and became haunted. I installed a cordless track ball and disabled the touch pad.

Worked for me!

Do you have a touchpad? Is it possible that you used to keep it turned off and now it has been turned on (possibly by the repair shop unknowingly or thinking they were helping)?

Many laptops have the ability to turn off the touchpad when you are typing, so you don’t have to disable it completely.

lol, yeah that’s not it. I’ve had this problem before, just don’t recall how to fix.

As I wrote in the OP, I’m using a touchpad, not a mouse. Don’t have a mouse.

Some touchpad drivers have a setting to momentarily disable the touchpad when you’re typing. Perhaps you had this setting on, and it got turned off at the shop.

Many touchpad drivers have a “tap to click” setting, where a somewhat firm tap on the touchpad will register as a left click. Possibly you disabled this setting when you had the problem before, and since it’s been in the shop the default setting has been restored.

Yep, that’s it.

Here’s the problem: I can’t seem to turn it off now. For my mouse, it’s telling me I have a “PS/2 Compatible Mouse” and I can’t do a thing with it. Googling around to little avail…

Hmm. And there’s no specific control panel for your touchpad? If you’re using some flavour of Windows, it might be worth a look in the Control Panel section.

Yeah, no, no control panel for my touchpad. Looked in Control Panel. From my googling, this is apparently a common problem with the ps/2 thing, but I can’t seem to find a fix for my toshiba.

You maybe brushing the touchpad with your cuff, or something.

There really should be controls for your touchpad somewhere. If not in control pannel, it may be an icon in your system tray (the little ones at the left of the taskbar, possibly hidden away until you click). I am pretty sure my wife’s Toshiba had its touchpad controls there.

People could probably give you more specific help if you said what version of Windows you are using.

Lookup your model on toshibas website, there should be an area where you can download the specific drivers for your model. Look for a touch pad driver, it will probably include the manufacturer specific control panel app. Many shops will just run with it if a default windows driver seems to be working rather than hunting down the hardware specific driver.

In that case I’d go to the Toshiba website and look for the specific model of laptop. In most cases, you can download the drivers from there, and those drivers should allow you to alter the touchpad behaviour to your preference.

Edit: Ninja drachillix strikes.

That did it! Thanks!