Win 7 hangs at the welcome screen

Since January, my Toshiba Satellite has turned on, gotten to the Welcome screen and been stuck. Enter doesn’t do anything, Ctrl+Sift+Esc doesn’t do anything. I got the computer in late March 2011 and it was fine for nine months and change.

I poked around a bit and it looks like two programs (or two processes, or two something-or-others) are doing an Alphonse-and-Gaston routine, but I can’t seem to selectively turn off just one of them, or even just both of them. I can use it in Safe Mode, but then I have no sound card, I can’t print, and nothing updates (also, I did a few restores, meaning the last few updates were dis-updated). My GF has Win 7 and her computer has updated lots and lots and I’m worried about what will happen if I fall too far behind on updates.

The page I linked up there offers a “hotfix” (a patch, except “patch” implies something is broken and we all know Microsoft products do not break). I got it, but it had no apparent effect, I suspect because I can only use the compuer in Safe Mode and so I installed it in such a way that it only works in Safe Mode (though now that I type that it doesn’t seem right to me).

Ideally I’d like to fix it without using any discs that may have come with the computer, because … I don’t remember any, and at any rate I lose track of things after nine months, certainly after 15.

TL;DR: Win 7 on a Toshiba hangs on welcome screen, found a patch, didn’t help.


Until someone who knows more comes along, I believe that you can create a system repair disc, and I’d guess you could do it in safe mode. It’s found under control panel/systems and security/backup and restore.

If you haven’t tried it yet, restoring to a backup point might also be an option.

I debated posting this, because I don’t know what I’m talking about, and my situation probably isn’t anything at all like yours, but just in case it helps:

Just last night, for the first time ever as far as I can remember, my computer running Windows Vista (not 7) got stuck on the Welcome screen.

After restarting in Safe Mode, I managed to find the help document “Run Selective Startup using System Configuration,” and by doing what it said (which basically involves telling the computer not to load some or all of the “system services” and “startup items” that it normally loads upon startup), I got it to work again.

:eek: I just spent a month or so dealing with this on both my Toshiba satellite (also bought last year) and my work laptop, which is an HP that just moved to Windows 7. Both now operate correctly as of the last few days. The issue on both also happened to relate to wi-fi…if that’s not your issue, ignore the rest of this.

On the Toshiba, I tried all these fixes, but I suspect the last (and simplest) one may have been the correct fix. I:

  1. tried some different static DNS addresses based on various web sites I found.
  2. restored to an old version prior to a bunch of updates
  3. deleted any references to my wireless router, then reconfigured it like it was new.
    It worked after #3.

On the HP, I was on the line with the help desk today. They took over my PC, deleted the old wireless configuration, and reattached to work wifi. It didn’t actually work 100% fine at the end of the day - some things like Lync worked fine, but Outlook was balky - so I’m going to re-check it out tomorrow morning.

Anyway. Good luck, I feel your pain.

Oh, PS: to get past the Welcome screen to do the reconfiguring on the Toshiba, I turned off that little wifi light at the top that tells it to look for wireless. In my case that’s apparently what hung it up: trying to resolve a bad wifi connection.

I got in by turning off a bunch of services, so now I have my screen and everything but I still don’t have sound, and I can’t install the not-a-patch. I might be on my way to solving those problems, but I don’t know.

Apparently I missed the edit window for both of those, but I got it back to the point where I could install things, and it told me the not-a-patch “is not applicable to your computer.” That suggests the link isn’t whatever my problem is. None the less, I’m trying to turn on everything except the aforementioned Alphonse.

Works now. Poking around in sysconfig helped. Thanks, Thudlow Boink! Thanks, everyone else!

I mean, I get a sense of fragility about it, and I don’t know why it now works, but it does work.

The basic strategy is to add things back one at a time in sysconfig, then restart, and see if it breaks. If not, add something else. Eventually you’ll find the one program that caused the problem–or it’ll just work and you won’t know why.

Also, do a thorough antivirus scan, just in case.

My girlfriend and I get into all sorts of, ah, discussions because she’ll say “is that fixed” and I’ll say “no, but it works.” Because there’s a difference.