Win7: Adminirstator permission for moving files between folders?!!

I have an external USB hard drive hooked up to my Windows 7 computer. If I try to move a file from one folder to another on this drive, a dialog pops up telling me I need administrator permission to do so. This is when I am logged on as an administrator. The dialog gives me a button to “Continue”, and if I click it the file does get moved as desired, so it is not actually preventing me from moving the files, just requiring an extra click, but it is very annoying having to do this every time. Does anyone know how to turn off this very irritating behavior so I can just click and drag files normally (like I can on my C drive)?

Setting User account control to “Never notify” did not help.

How is the drive formatted? Assuming NTFS you could change permissions so any user is allowed to read and write.

Yes, NTFS.

I am the only user.

The directory structure on the external drive, and most of the files, were created (by me) on another computer, though, which may have something to do with it. Also,it seems to let me copy files without this nag screen, just not move or delete them.

How do I change the permissions (for the whole drive, I guess)?

“Taking ownership” of the drive (I think I did it right) does not seem to help either.

I’m not a computer wizard so can’t really help. I expect it to be to do with permissions and rather than taking ownership have you tried giving permissions to everyone (right click propertiess - security - add - in bottom box type “everyone”(quite literally - press “check names” if you’re unsure after doing so) - then click ok to let anyone modify yer flash stuff. Although of course you gotta be happy with that, but I guess you are :wink:

Download/install the Take Ownership registry hack. Been using it since Day One.