Windows 2000 running SLOW

My work PC has decided that life in the slow lane is much better, I guess.

I can’t pinpoint when it happened, but all of a sudden my PC is running much, much slower. I have not loaded any new software (save for the patch for Windows 2000).

My pc takes 15 minutes to boot.

Word 2000 takes over 30 seconds to load (the first time - nearly instantaneous after that).

Excel take over 45 seconds to load.

I’ve had this problem before, but it was cleared up by rebuilding the page file. I tried to do that this time by deleting the file size, rebooting, and then setting the file size (both initial and maximum) to 381 Mg.

Any other hints??

No viruses and the disk is being defragmented now.

Check for a temp file on your HD. Win2K for some reason has the annoying habit of creating a massive temp file that it doesn’t like to delete and just grows and grows. That can really bog down your machine. Find it, and delete it, and you should be okay. (Of course, that might not be the problem, but it’s pretty common.)

You might want to defrag your hard drive.Sometimes that will help.But my money is on what Tuckerfan said about looking for really big temp files, I’ve had that happen a few times.

Where do I find Windows temp files? Do I just delete everything in the c:\windows emp folder? Including the folders within the c:\windows emp folder?

I set the defragger to work before I left last night. I’ll check on it in a bit to see how well that worked.

This may not be applicable to you (I have Windows XP), but Microsoft released a patch (811493, IIRC, but you can look it up) which actually slowed down the loading of programs.

This was a security patch and no one, including Microsoft, knows why it caused the slowdown (they’re looking at it). Anyway, removing the patch got my system running as before.

I would also suggest that you lookup the Microsoft newsgroups at (it’s free to join) or you can find similar groups on Google Groups.

Check out any of the Windows 2000 groups. They always have excellent experts there who can answer questions like this.


In addition to all the other good advice, see if there’s a junk process running all the time. CTRL-ALT-DEL, click the “Task Manager” button, then the “Processes” tab. Click the “CPU” column, and see what’s using most CPU resources. Then click the “Mem Usage” column and see what’s using most memory. It might be that you’ve got something chugging away in the background that’s not meant to be there.

Just yesterday I was having a similar problem. But mainly a problem with windows explorer. In my case I had a mapping to a share that no longer existed on the network. I booted up in safe mode w/ networking (hit F8 when windows starts to load) and windows didn’t operate in sloooow mode. I was then able to identify which network mapping was at fault and remove it. Windows worked normally after this.

Yup. It may whine and not let you delete the folder unless you fiddle with the settings or you may have to go in and delete each file manually (it’s been a long time since I’ve played with Win2K), but that should do it.

I suggest downloading Ad-Aware from
This program is useful for detecting junk processes that have been loaded surreptitiously by web sites that you visit. One of these programs might be the culprit.

You might also check the BIOS settings, which can sometimes reconfigure themselves on a power surge or an improper shutdown. See if the speed reported in your BIOS settings is what it’s actually supposed to be (perhaps the multiplier got knocked down a few notches). I’ve also seen this happen if the Level 2 cache is disabled (in the BIOS) or has simply stopped working (a common problem in early IBM Pentium-class computers).

Also check your Event Viewer. Perhaps something got set to audit every little disk access or API call. Look for lots of entries very close together timewise and the Source column will hopefully provide clues as to what process is causing all the entries.

Does the hard drive grind (LED blinking continuously) when booting up or does it stay on for many seconds at a time and you don’t hear any disk access? The latter could indicate a failing hard drive which would explain why Office apps load slowly the first time and much faster subsequently (the dll’s are already in memory). If the hard drive light goes out for many seconds at a time it could indicate a network problem, from the port to wiring or even the switch you’re plugged in to (and also cause some delay while working in Windows). Simply unplug the network cable and boot up to test this.

I’ve tried to delete the temporary files with no luck.

I haven’t checked the bios yet, but I will the next time I reboot.

Support has been by my desk and after some checking around the event logs, they determined it was an IP buffer overflow or something. They tried to clean that up, but it still takes 15 minutes to reboot. There not appear to be a specific problem with one program checking very little access to disk.

Next, they started chkdsk which took over 4 hours to run on a 20 Gig drive. Nothing of note came of that. Support will be back tomorrow to do more checking.

I’ve checked taskmanager for runaway processes, but there aren’t any.

I’ve used google to search usenet and the web, but there wasn’t much help that I could find. I think my search terms aren’t specific enough, though. I can’t define my problem beyond “windows runs slow” and that just doesn’t seem to be me very far.

Bootup seems to have a solid disk light, and I can hear the disk being accessed, I think. I’ll check it more carefully next time and see if I can be more specific. There certainly aren’t long periods when the light is off, that is for sure.

THAT sounds familiar. Windows normally reads more data from the HD and holds it in memory, figuring that if you read blocks A and B then you might also need block C. This greatly speeds loading of files. If this has somehow gotten turned off (or the read ahead value set way low,) then things will slow to a crawl - most especially if you are low on memory and Windows must use the pagefile.

I don’t use Windows anymore, so I can’t tell you exactly where to find the settings. It should be in the hardware management and most likely you can set it for each individual drive. It should be something like “HD caching” or “HD Read ahead.”

You will need Administrator rights to change the settings, and possibly even just to look at the settings.

My roommate upgraded from 98 to 2000, and it ran exactly like yours.

The problem with his was he had set it to NTFS instead of Fat32 during the install.

Nothing to do with your problem, but thought I would throw that out there.

Just in case someone else does a search on this topic and they’d like to know what my problem ended up being:

It was the hard drive. The support group imaged my drive to another drive and now the machine runs great. Boot up time is back to around 4 minutes, and app startup is down under 5 seconds.

Thanks to all who helped and offered suggestions! Special recognition is hereby given to Horseflesh for suggesting the right answer.