Windows restart

My office computer is a PC. Every couple of weeks there are updates. As I work, I get a pop-up window that says ‘Updates are almost complete. You must restart your computer. [Restart now] [Restart later]’. It’s annoying when I’m in the office. When I’m telecommuting it’s a pain. If I click Restart now, it will restart the office computer. Only when I log back in my # sign becomes a £ sign, my @ becomes " and my " becomes @. Maybe some other things, but I haven’t noticed. To prevent this, I have to call my office mate and have her restart the PC at my desk.

On my Mac, when a restart is required, I can tell it I’ll do it later and it doesn’t bother me again. On the PC, the window pops up every ten minutes. Of course it pops up when I’m in the middle of something, and things I’d just typed aren’t there. Close, and retype.

Is there a way to tell it ‘Restart later, and don’t bother me again. My memory is not so far gone that I’ll forget to restart tomorrow.’?

No. It used to be like this during the pre-SP2 XP days and no one did updates and things like active x exploits and blaster ruled the earth. You can set it to download and install them updates at a certain time, like 3am, so you dont see any nag screens. Right now it sounds like you have it on download and notify me.

No idea, but that sure isnt typical.

net stop wuauserv

Type that at a command prompt, and it’ll stop the Windows Update service and make the reminders go away.

Probably not a great idea, as many of the updates are to counter security issues. You can set (on Vista and 7, at least) updates to download automatically, but install them when you want.

No idea why it happens, but it looks like you’re changing to a UK keyboard.

The Windows update service will still start with the next boot, so it’s not a big risk. However a better approach is to modify the reminder setting using the group policy editor.

start -> run -> gpedit.msc

Local Computer Policy
Computer Configuration
Administrative Templates
Windows Components
Windows Update

Either, “No auto-restart for schedule Automatic Updates installations” -> enable
or “Re-prompt for restart with scheduled installations” -> 1440

Remove the alternate UK keyboard;

Control Panel
Regional and Language Options
Select UK keyboard and Remove

Starting with Vista, the Windows Update reboot reminder dialog allows you specify how long you would like to wait before being reminded again (minutes, hours or even [a] day).

The options, at least on this machine, are 10 minutes, 1 hour, and 4 hours

I’d leave it to the next restart. It has switched between UK and US keyboard mapping. You need to reset Keyboard in the Control Panel.