Windows XP Annoyances--Help

Ok, I’ve made the switch to XP and…eh…it’s…ok I suppose, but I’ve never, ever had an OS where I had to turn off so much crapware, bells and whistles and idiot-proofing features as I have here. Pfui.

That said, I’m here and it’s working, but there’s one or two features that are driving me nuts but don’t really affect functionality. ANY help would be appreciated.

  1. Most important feature to kill: This is hard to describe. I’m using the “Windows Classic” look, not the “Blue Meanie” default. On the toolbar, between the quickstart area and the tray are a series of buttons that appear when programs are opened. Here’s what’s hard to describe–they behave differently than they did in 2K, and I’m not exactly sure I can describe how.

Open four or five applications. Then open another and watch the task-bar. The icons will, for lack of a better word, grow and shrink. They don’t just change size, there’s an animation involved which I find as distracting as hell. The stupid buttons shrink or grow to fill the toolbar so there’s no empty space. If you only have two buttons, they’ll fill the space between the quickstart area and the tray. On 2K, the buttons had a fixed maximum size so the button-size didn’t change as much.

As it is, as often as I open and shut windows, It’s like there’s this annoying little dance going on down there. (Plus I hate the sliding animation). I’d swear that I’d seen how to disable that in the registry on the “Windows Annoyances” page, but since they’ve gone sort-of commerical, they’re really hard to use.There must be a way to turn this off. It keeps catching the corner of my eye and I keep having to glance at the toolbar. Playing with the “lock toolbar” feature doesn’t do it, neither does the “group toolbar options” one. HELP! This “feature” alone is bugging me enough that I’m almost tempted to revert back to 2K.

  1. There’s some sort of idiot media control panel. Every time I put in a new cd/dvd/etc, it pops up and asks me what I want to do. How the hell do I kill it? I have real applications that can play it and I want to use them without having to go through an extra screen to click. Yeah, I can click on “Choose this action each time” for each type of media I insert, but isn’t there just a way to turn it off?

Thanks for any advice, and expect more questions later! :slight_smile:

Fenris

I would advise that you download and install TweakUI for XP. This utility has many tweaks which will fix/adjust some of the annoyances you are describing. Power Toys. Check it out.

Actually, I have DL’d TweakUI…if there’s a setting that can fix either annoyance, I can’t find it. Could you walk me through where those settings in TweakUI are?

Thanks! :slight_smile:

Disabling cd autoplay (#2 on your list). Open up regedit (go to start button --> run, type in “regedit”) and go to the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom

Under the list of boxes on the right change “Autorun” to 0 (numerical).

You can do this under TweakUI, as well, but I wind up using this more often. It’s the only way to be sure. :slight_smile:

Er, I should add that you should only do this if you’re comfortable playing with the registry.

Perhaps in the Display settings, on the Apperance tab, if you set it to Windows Classic style rather than XP?

Or Control Panel/System/Advanced/Visual Effects: Slide taskbar buttons. Turn that off.

Open Tweak and look under the General Tab for a list of animations that can be controlled. I am not exactly certain though if this will help the problem you describe in the Taskbar.

Control Panel->System->Advanced Tab->Performance Settings

You can turn on/off all the funky sliding/fading/etc. in there. I saw one for “Slide Taskbar Buttons” which sounds like your issue.

That did it! Thanks folks, you all rock!

:slight_smile: