Wireless network connection problem: need help fast

I’m embarrassed to post this since I am a networking guy but this one has me stymied. Worse, I am troubleshooting over the phone (if I was there think I could sort it).

My boss has a LinkSys wireless router. I rebuilt an old PC for him in the office and installed a new LinkSys wireless card. Worked great in the office, all was well.

He took it home and somehow it got all bollixed up.

Long story short the wireless card seems to connect to the wireless router (gives a message something like “Great! You Rock! You are now connected!”). However, the card stays in “scanning” mode and never actually seems to get a DHCP address.

I have been troubleshooting this for awhile and remember this is remotely but if anyone has an idea of what the issue may be I’d like to hear it.

I am a techie guy so no need to dumb things down. Lay the techno babble on thick if you want.

Thanks in advance!

Phone support? Bummer.

I’d suggest logging incoming DHCP requests to the router to see if the client’s requests for an IP are even being received. Not seeing at the router doesn’t mean it’s not going out, the next step would be Wireshark on the local machine to see what’s happening with the packets there.

You’ve still got a number of possibilities, but I had almost the exact same problem lately. Installed ethernet over powerlines, the War Department’s desktop would not get a DHCP assignment from the router. 3 laptops plugged into the same connection produced near-instant assignments. Turns out the onboard NIC card on the mobo took a dump, had to get a $10 card from Fry’s and the problem went away.

Whenever i come across similar issues, its usually down to the security settings. It’s also the easiest to test, but as a techie I expect you’ve already tried removing WEP, WPA, whatever from the router…

It sounds like the wireless router settings have been tweaked from factory default at some point. Nothing you can do over the phone will help unless you can have him hard reset the router and then set the security yourself. Get his model and BIOS hardware version then DL the appropriate manual. The hardware setup address for most linksys routers is

In these cases it’s usually simpler to just to go to his house and do the setup personally.

I had a similar issue that had me tearing my hair out for a few days… it turned out to be a bad ethernet cable between the router and modem that was shorting the router out and causing it to behave as if it were possessed.

Don’t forget to check out the simple things!

I can’t offer any specific solution without looking at the settings on the PC, but instead of phone support I find it much easier to use CoPilot to connect and take-over control of the PC I’m troubleshooting:

http://www.copilot.com (free on weekends, paid on weekdays)

ETA: You can also connect to the router control panel through the PC if you ask him to hook the router up to the PC using a network cable while you’re troubleshooting router settings.

Does the router have MAC address filtering enabled?


TeamViewer is free 7 days a week :cool:

Of course, this does not help anyone whose computer is unable to get a DHCP assignment from the router and thus a connection to the internet.

The most recent time this happened to me (2 weeks ago), I turned off the router and back on again and that fixed it.


As a workaround, you could get the bossman to connect the computer directly to the Internet (without router) first, to check/change settings, and then do a dance between the two connections.