Wireless problem, any hints?

Hiya. My son has been given a laptop running Windows 7. For some reason it can’t see our Belkin wireless router although it can detect the neighbours’ wirelesses just fine and every other computer in the house can see our own wireless (including the PC I’m composing this very post on). Any thoughts?

Is your wireless router actually broadcasting the SSID? If it isn’t then it won’t appear when you scan but devices will still be able to connect to it if they have been set up to do so. Try creating the connection manually (you will need to know the SSID, encryption type and passphrase).

Thanks, I have now tried that (only saw Windows 7 for the first time a week or so ago, so trying what looks obvious) but even after telling it to connect to “FRED”, which is an unsecured wireless network, “FRED” doesn’t appear in its list, nor will it connect automatically even though I have told it to even if the SSID is not being broadcast. :frowning:

Is it looking on the right channel?

How locked-down is your router? If you’ve enabled MAC address filtering on the router, you’ll need to tell the router the MAC address of the laptop before it will work.

Try installing inSSIDer or Netstumbler and see if they pick up the network. Why is your network unsecured? That is a bad idea unless you have activated MAC filtering as mentioned above or unless you live somewhere very remote.

  1. I don’t know what channel it is, or should be, looking on, or how to tell it to look elsewhere. But if that’s configurable then it could be a place to look - see below.

  2. I don’t know, I just plugged it in and let it go :). But after originally installing it for the PC I’m now using (not in the same room as our “main” PC) I had no difficulty with my own laptop that I bought later that year, and house guests have been able to use the wifi too.

  1. I have installed inSSIDer and the problem laptop cannot see “FRED” although both this PC and my laptop are receiving it loud and clear on channel 13. The other SSIDs that they can all see are all on lower channels (6, 7 and 11).

  2. I’m in a rural location with two trusted next-door neighbours and it’s not likely anyone will stop in the street outside on the off-chance of hacking my wifi, so I’ve left well enough alone until now. :slight_smile:

Thanks in anticipation of further advice - if there’s just a setting somewhere that is discouraging the problem laptop from finding channel 13 then we may be in business.

You can try logging in to your router and changing the channel it broadcasts on but I personally have never encountered a wireless adapter that doesn’t work only on particular channels.

Does your wireless adapter have software with it that you can use to scan for networks, you can usually just use the one built in to Windows with no issues but sometimes you get better results using the profile manager provided by the manufacturer.

Beyond that I would be tempted to reset the router to factory defaults and set it up again, try adding some security to the network if it still doesn’t detect it.

On the laptop side you can try checking for driver updates for the adapter or uninstalling the device in device manager and letting Windows re-install it.

In the USA, channels 12-14 are somewhat restricted - they’re legal but only with certain limitations. It’s possible your son’s laptop either ignores them, or will work only at a shorter range than usual.

Heh. I have changed FRED to broadcast on channel 3 instead of 13 and guess what…?

Strangely, I’m 99% sure my father-in-law had no wireless problems with this same laptop before he cleaned it down and installed Windows 7 to give it to my son. But post hoc fallacy and all that - as long as it’s working, I’m not going to complain!

Cool, looks like tellyworth was on to something, I don’t live in the USA so have never encountered this problem with the higher channels.

I’m not in the USA either - didn’t see **tellyworth’s **post before I made the change. All’s well that ends well anyway (and I may even get around to securing the thing too). :slight_smile: